Page MenuHomePhabricator

The insert menu in VE is awkward
Closed, InvalidPublic

Description

Depending on the use some of the items in the insert menu has an awkward position. After nowiki started to focus more on use of sources it became clear that the references-tag was used so much that it should be placed above the "more" marker.

I wonder if the problem is that the "more" solution adds complexity to something that is simple. It should not be there, as it hides important functionality. One solution could be to dynamically move elements above the "more" line, another could be to add a dynamically constructed speedbar.

Event Timeline

jeblad created this task.May 12 2016, 3:18 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 12 2016, 3:18 AM

This is an issue of several discussed at w:no:Wikipedia:Bazar.

Elitre added a subscriber: Elitre.May 12 2016, 12:14 PM

This task would benefit from being more focussed; as I read it, there are four different comments here, which should be treated individually. In future, please split up your comments so they can be responded to better.

  • The shortened menus are better than the alternative, from our user testing, which is why we moved to them. There is always a hierarchy of importance between tools (the really important buttons are directly on the toolbar, for instance; bold and italics were moved out of the toolbar due to the relative infrequency and intentional discouragement of use). I don't agree that having e.g. a list of twenty different kinds of thing to insert serves users better.
  • Moving references list up "above the fold" feels like a bad outcome. For the vast majority of articles, there is only one references list, whereas there are (or should be) dozens of references and links, and a handful of templates and media.
  • I don't understand what you mean by "a dynamically constructed speedbar" (toolbar?) – the toolbar is already dynamic (which is why "Graph" appears there on wikis on which it's available). Perhaps you mean that it should be ordered based on what the individual user most often uses? This is possible (and already reported I think, though I can't find it now, sorry), though I worry that this would make interfaces even less explicable and more inconsistent for users when they e.g. change between wikis or accounts or are logged out.
  • The references list issue is more interestingly solved with T56906: Append a references list to bottom of the page when the first reference is added, I think (but you're right, it's mildly irritating right now).
Jdforrester-WMF changed the task status from Open to Stalled.May 24 2016, 7:24 PM
  • I do remember the first discussions about shortened menus on various programs in the late 90s, it should solve all kinds of problems. It never did. It is an awful solution that only hides complexity instead of solving it.
    • The shortened menus should be removed. Period.
    • A site-wide adaption isn't adaption, it is automated configuration.
    • Different solution to a single item that is now done through a hidden menu item. Not a general solution.

This still has no solution.

jeblad closed this task as Invalid.Feb 7 2018, 2:35 PM