Page MenuHomePhabricator

[BUG] Image not shown for Content Service file pages
Closed, ResolvedPublic2 Estimate Story Points

Description

Steps to reproduce

  1. Go to the Carolina Panthers page.
  2. Tap the lead image.
  3. Go to file page.

Expected results

The appears like the MediaWiki equivalent:

Actual results

No image is shown:

Environments observed

App version: f80964f08004c02225c92edf86dd40aa246e09ce
Android OS versions: API 23
Device model: Nexus 6P
Device language: English

Details

Related Gerrit Patches:
apps/android/wikipedia : masterLoad File pages with api.php

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 13 2016, 3:46 PM
MBinder_WMF set the point value for this task to 2.Sep 23 2016, 6:26 PM
Mholloway moved this task from To Do to Doing on the Mobile-App-Android-Sprint-92-Uranium board.
Mholloway added a project: Parsoid.EditedSep 28 2016, 7:05 PM
Mholloway added a subscriber: bearND.

It appears that the image and surrounding UI elements on a wiki File page are generated with some magical MediaWiki parser transclusion that Parsoid isn't doing. I'm guessing from the Parsoid perspective this is working as intended, but I'll tag the project for comment.

From the client perspective the (hopefully) easiest fix would be to just load File pages from api.php in the meantime. @bearND agreed?

Interesting. We'll have to fix this in Parsoid in any case. We'll take a look at what is going on and what kind of magic is being invoked and see if there is a way to do a native Parsoid implementation of it. But, may not happen right away since we are heading into 2 back to back offsites.

Change 313320 had a related patch set uploaded (by Mholloway):
Load File pages with api.php

https://gerrit.wikimedia.org/r/313320

Change 313320 merged by jenkins-bot:
Load File pages with api.php

https://gerrit.wikimedia.org/r/313320

From the client perspective the (hopefully) easiest fix would be to just load File pages from api.php in the meantime. @bearND agreed?

Agreed. Thank you! I also agree that we should revert the patch once Parsoid has fixed the issue, as you've mentioned in the patch in a TODO comment.

Marked it with Regression tag to better track changes other clients of MCS need to be aware of when transitioning from mobileview action to MCS.

Hi, I won't be able to check this yet as the last successful build on WMFlabs.org is for 9/13 and the build I was sent on 9/28 by @Mholloway isn't showing fixes either. If there is a newer build or another link/directory for new builds please let me know. Thanks.

@Nicholas.tsg Emailed you an updated APK.

Testing Galaxy Express 3 (Android 6.0.1) with Wikipedia app 2.4.157-alpha-2016-10-03. Now it is fixed as I can see the lead image on the file page.

Dbrant closed this task as Resolved.Oct 11 2016, 2:12 PM

I've created a subtask for Parsoid since there is still has work to do in this regard.
What we did in the Android app is to work around the issue by not using MCS/Parsoid for those pages.