Page MenuHomePhabricator

Wrong notification counts being shown due to cache pollution coming from non-SUL wikis
Closed, ResolvedPublic

Description

From IRC today (UTC times)
15:38 <anomie> Trizek: Another notification bug: On wikimediafoundation.org it's showing me (User:BJorsch) 4 alerts and 6 messages. But the dropdowns, and going to Special:Notifications, say "You have no notifications". Force-reloading doesn't change this situation.
16:01 <Trizek> Is that happen before, anomie?
16:08 <anomie> Trizek: Nope, just started today. I had strangely high numbers of notifications reported on officewiki too (lots of alerts and messages reported, even though there was actually only 1 new message), but that correctly went back to 0 after opening the dropdowns.

Details

Related Gerrit Patches:

Event Timeline

Trizek-WMF renamed this task from Possible regressions on notifications on wikimediafoundation wiki and office wiki due to last Notifications release to Bugs on notifications on wikimediafoundation wiki and office wiki, possibly due to last Notifications release.May 13 2016, 4:32 PM
Trizek-WMF created this task.

This seems to be a fishbowl wiki issue, where the counter returns local + crosswiki notifications, but the wiki itself doesn't have access to get the cross-wiki and so it doesn't actually show the bundle, making the view and counter different.

Private and fishbowl are not on CentralAuth, so there are no cross-wiki notifications. Like @Catrope said, it is probably just returning the wrong data due to user ID collisions with actual CentralAuth users.

Change 288651 had a related patch set uploaded (by Mattflaschen):
Disable cross-wiki notif. (both Beta and separate pref.) on non-SUL

https://gerrit.wikimedia.org/r/288651

Change 288654 had a related patch set uploaded (by Mattflaschen):
Bump cache version for cache pollution (cross-wiki on non-SUL wikis)

https://gerrit.wikimedia.org/r/288654

Change 288651 merged by jenkins-bot:
Disable cross-wiki notif. (both Beta and separate pref.) on non-SUL

https://gerrit.wikimedia.org/r/288651

Never mind, @Catrope explained we do have to do that now.

Config change deployed.

Change 288654 merged by jenkins-bot:
Bump cache version for cache pollution (cross-wiki on non-SUL wikis)

https://gerrit.wikimedia.org/r/288654

Change 288710 had a related patch set uploaded (by Catrope):
Bump cache version for cache pollution (cross-wiki on non-SUL wikis)

https://gerrit.wikimedia.org/r/288710

The cache pollution (i.e. wrong notification counts) should be fixed now, and cross-wiki notifications should now be fully disabled on wikis that don't have CentralAuth. Let us know if you still see issues.

Catrope renamed this task from Bugs on notifications on wikimediafoundation wiki and office wiki, possibly due to last Notifications release to Wrong notification counts being shown due to cache pollution coming from non-SUL wikis.May 13 2016, 10:02 PM

Change 288710 merged by jenkins-bot:
Bump cache version for cache pollution (cross-wiki on non-SUL wikis)

https://gerrit.wikimedia.org/r/288710

Etonkovidova added a comment.EditedMay 14 2016, 12:55 AM

Checking before the fix


@Catrope and @Mattflaschen, please review the attached screen recording. 'X' button has a different behavior there vs enwiki. Not sure if the issue described below is related to the problem fixed in that ticket.

Re-checking after the fix - there are still some problems with updating the counter - not observed in enwiki or testwiki, but it's present in Hindi wiki.

Do we have 'mark as unread' state for a bundle?

  1. Without opening the bundle - click on the the 'X' icon to mark as read all bundled notifications.
  2. The bundle will be greyed out and have an option 'mark as unread'
  3. Click on 'mark as unread' - the bundle is unread.

All those actions mess up the counter - watch the counter goes from 10 to 5, flickering 0, back to 5.
The final count will be incorrect 5 - and no hard-refresh or navigating away will change that count.

Or, as in the case with Arabic wikipedia

I think the comment above is attached to the wrong task. (This task is about notification counts at the private/fishbowl wikis, e.g. wmfwiki and officewiki).

I'm not sure which is the correct task to copy it to. Possibly T124948: Unread notification count is wrong when presentationModel::canRender() returns false? Or does it need a new task?
See also the related T135292: Expandable cross-wiki bundle notification count does not get updated after some messages were marked as read.

Catrope closed this task as Resolved.May 16 2016, 9:44 PM