Page MenuHomePhabricator

[betalabs] "Request to parsoid for 'wikitext' to 'html' conversion failed" for for any edits
Closed, ResolvedPublic

Description

  1. In betalabs, try to reply/edit any post or a board description.
  2. When Save is clicked the following is displayed, e.g.

Exception Caught: Request to parsoid for 'wikitext' to 'html' conversion of content connected to title "Tema:T3wdm8dwnpvnystn" failed: 406

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 13 2016, 8:18 PM

Change 288725 had a related patch set uploaded (by Mattflaschen):
Update Parsoid version string

https://gerrit.wikimedia.org/r/288725

It turns out Parsoid changed their version string. They are going to temporarily turn off the validation, but this should also fix it on our side.

Change 288725 merged by jenkins-bot:
Update Parsoid version string

https://gerrit.wikimedia.org/r/288725

No parsoid errors in betalabs.

@Mattflaschen

Not sure if the following is related to the fix. It's not a bug per se, but the functionality looks awkward.

  • a user is able to start typing a reply to a resolved topic - no indication that replies cannot be saved.
  • only after clicking on 'Reply' button the warning appears: "This topic is resolved, so further activity is not possible."
  • clicking on Cancel will bring the irrelevant VE popup about 'Continue editing' or 'Discard changes'

Please file separately. It is not connected.

jmatazzoni closed this task as Resolved.May 20 2016, 5:22 PM