Page MenuHomePhabricator

{{DISPLAYTITLE}} notation causes problems with certain HTML entities like & (Ampersand)
Closed, InvalidPublic

Description

Hello Cindy,

when using some characters like & in the {{DISPLAYTITLE}} parser function, they will be replaced by their corresponding HTML entity.

Steps to reproduce: Create any page with something like:

{{DISPLAYTITLE:Web & Wine}}

Go to SMW Browse Properties, or select the page via ASK query. The resulting link will be correct, but the page name will be:

Web & Wine

I guess this has to do with the displaytitle parser function of MW itself.

We're using MW 1.25 and SMW 2.4

Event Timeline

Fannon created this task.May 24 2016, 2:51 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 24 2016, 2:51 PM

I've tryed around and found that the bug is not caused by {{displaytitle itself, nor the Semantic Title extension.

The problem seems to lie in the implementation of SMW's "native" displaytitle support, probably this pull request: https://github.com/SemanticMediaWiki/SemanticMediaWiki/pull/1410

Thanks for reporting this! I agree with your assessment that this is SMW related.

cicalese closed this task as Invalid.Nov 28 2016, 8:09 PM

I'm not sure "invalid" is the correct status, but I believe it was resolved that this is an issue with SMW, not SemanticTitle, right?

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 31 2019, 3:46 PM