Page MenuHomePhabricator

Exception page when trying to login - "Could not find local user data for user"
Closed, DuplicatePublic

Description

It happened to me today while trying to login on meta or enwiki: Exception encountered, of type "Exception"

I've seen this stack in the log:

2016-05-26 22:58:28 [V0d-lApAMFwAAFzfE8cAAAAJ] mw1257 enwiki 1.28.0-wmf.3 exception ERROR: [V0d-lApAMFwAAFzfE8cAAAAJ] /w/index.php?title=Special:UserLogin&action=submitlogin&type=login&returnto=Main+Page Exception from line 2313 of /srv/mediawiki/php-1.28.0-wmf.3/extensions/CentralAuth/includes/CentralAuthUser.php: Could not find local user data for DCausse (WMF)@tawiki {"exception_id":"V0d-lApAMFwAAFzfE8cAAAAJ"} 
[Exception Exception] (/srv/mediawiki/php-1.28.0-wmf.3/extensions/CentralAuth/includes/CentralAuthUser.php:2313) Could not find local user data for DCausse (WMF)@tawiki
  #0 /srv/mediawiki/php-1.28.0-wmf.3/extensions/CentralAuth/includes/CentralAuthUser.php(2253): CentralAuthUser->localUserData(string)
  #1 /srv/mediawiki/php-1.28.0-wmf.3/extensions/CentralAuth/includes/CentralAuthUser.php(2213): CentralAuthUser->queryAttached()
  #2 /srv/mediawiki/wmf-config/CommonSettings.php(399): CentralAuthUser->getLocalGroups()
  #3 /srv/mediawiki/php-1.28.0-wmf.3/includes/Hooks.php(195): Closure$wmfLoadInitialiseSettings#2(User, array, string)
  #4 /srv/mediawiki/php-1.28.0-wmf.3/includes/password/UserPasswordPolicy.php(150): Hooks::run(string, array)
  #5 /srv/mediawiki/php-1.28.0-wmf.3/includes/password/UserPasswordPolicy.php(75): UserPasswordPolicy->getPoliciesForUser(User, string)
  #6 /srv/mediawiki/php-1.28.0-wmf.3/includes/user/User.php(1071): UserPasswordPolicy->checkUserPassword(User, string, string)
  #7 /srv/mediawiki/php-1.28.0-wmf.3/includes/user/User.php(4272): User->checkPasswordValidity(string)
  #8 /srv/mediawiki/php-1.28.0-wmf.3/includes/specials/pre-authmanager/SpecialUserlogin.php(817): User->checkPassword(string)
  #9 /srv/mediawiki/php-1.28.0-wmf.3/includes/specials/pre-authmanager/SpecialUserlogin.php(1064): LoginFormPreAuthManager->authenticateUserData()
  #10 /srv/mediawiki/php-1.28.0-wmf.3/includes/specials/pre-authmanager/SpecialUserlogin.php(367): LoginFormPreAuthManager->processLogin()
  #11 /srv/mediawiki/php-1.28.0-wmf.3/includes/specialpage/LoginSignupSpecialPage.php(1410): LoginFormPreAuthManager->execute(NULL)
  #12 /srv/mediawiki/php-1.28.0-wmf.3/includes/specialpage/SpecialPage.php(479): LoginForm->execute(NULL)
  #13 /srv/mediawiki/php-1.28.0-wmf.3/includes/specialpage/SpecialPageFactory.php(591): SpecialPage->run(NULL)
  #14 /srv/mediawiki/php-1.28.0-wmf.3/includes/MediaWiki.php(282): SpecialPageFactory::executePath(Title, RequestContext)
  #15 /srv/mediawiki/php-1.28.0-wmf.3/includes/MediaWiki.php(746): MediaWiki->performRequest()
  #16 /srv/mediawiki/php-1.28.0-wmf.3/includes/MediaWiki.php(520): MediaWiki->main()
  #17 /srv/mediawiki/php-1.28.0-wmf.3/index.php(43): MediaWiki->run()
  #18 /srv/mediawiki/w/index.php(3): include(string)
  #19 {main}

Explicitely login to tawiki fixed the issue.

Event Timeline

dcausse created this task.May 26 2016, 11:10 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 26 2016, 11:10 PM
Danny_B renamed this task from Exception page when trying to login to Exception page when trying to login - "Could not find local user data for user".May 27 2016, 1:14 AM

If you login at tawiki should fix it (@jcrespo was experiencing it earlier today)

I've tried to merge it into T119736: Could not find local user data for {Username}@{wiki} as a duplicate but phab does nothing.