Page MenuHomePhabricator

Removal of all coordinates doesn't remove them from ES index
Closed, ResolvedPublic

Description

Example query: https://en.wikipedia.org/w/api.php?action=query&format=json&list=geosearch&gscoord=0%7C0&gsradius=10000
Of results there, only Null Island is valid, all the other pages had these coordinates in the past, but don't have them anymore.

According to Erik, this might be caused by our use of upserts for updates.

Event Timeline

MaxSem created this task.Jun 1 2016, 12:49 AM
Restricted Application added projects: Discovery, Discovery-Search. · View Herald TranscriptJun 1 2016, 12:49 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald Transcript

Change 293134 had a related patch set uploaded (by MaxSem):
Set empty coordinates field if no coordinates found

https://gerrit.wikimedia.org/r/293134

MaxSem moved this task from Backlog to Needs review on the Maps-Sprint board.
MaxSem claimed this task.

Change 293134 merged by jenkins-bot:
Set empty coordinates field if no coordinates found

https://gerrit.wikimedia.org/r/293134

MaxSem closed this task as Resolved.Jun 7 2016, 6:54 PM