Page MenuHomePhabricator

Investigate how to increase edit stash hit rate
Closed, ResolvedPublic

Description

https://grafana-admin.wikimedia.org/dashboard/db/edit-stash shows that even without bots not being counted, the cache hit rate is 25% or so. It would be nice to get this up.

Also related is what can be done to exclude more case that don't matter (e.g. doRollback()) from skewing the numbers.

Details

ProjectBranchLines +/-Subject
mediawiki/coremaster+30 -7
mediawiki/coremaster+13 -8
mediawiki/corewmf/1.28.0-wmf.6+13 -8
mediawiki/corewmf/1.28.0-wmf.6+2 -1
mediawiki/corewmf/1.28.0-wmf.5+2 -1
mediawiki/coremaster+2 -1
mediawiki/corewmf/1.28.0-wmf.6+21 -84
mediawiki/coremaster+21 -84
mediawiki/corewmf/1.28.0-wmf.6+43 -13
mediawiki/coremaster+43 -13
mediawiki/corewmf/1.28.0-wmf.5+39 -23
mediawiki/coremaster+39 -23
mediawiki/corewmf/1.28.0-wmf.5+16 -3
mediawiki/coremaster+16 -3
mediawiki/coremaster+6 -2
mediawiki/corewmf/1.28.0-wmf.4+6 -2
mediawiki/coremaster+2 -1
mediawiki/corewmf/1.28.0-wmf.4+2 -1
Show related patches Customize query in gerrit

Event Timeline

aaron created this task.Jun 1 2016, 6:51 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 1 2016, 6:51 AM

Change 292520 had a related patch set uploaded (by Aaron Schulz):
Avoid rollback and bot flagged edits in edit stash stats

https://gerrit.wikimedia.org/r/292520

Change 292977 had a related patch set uploaded (by Aaron Schulz):
Avoid rollback and bot flagged edits in edit stash stats

https://gerrit.wikimedia.org/r/292977

Change 292977 merged by jenkins-bot:
Avoid rollback and bot flagged edits in edit stash stats

https://gerrit.wikimedia.org/r/292977

Change 292520 merged by Aaron Schulz:
Avoid rollback and bot flagged edits in edit stash stats

https://gerrit.wikimedia.org/r/292520

Change 293030 had a related patch set uploaded (by Aaron Schulz):
Make edit stash keys less preference sensitive

https://gerrit.wikimedia.org/r/293030

Change 293033 had a related patch set uploaded (by Aaron Schulz):
Make edit stash keys less preference sensitive

https://gerrit.wikimedia.org/r/293033

Change 293033 merged by jenkins-bot:
Make edit stash keys less preference sensitive

https://gerrit.wikimedia.org/r/293033

Change 293030 merged by jenkins-bot:
Make edit stash keys less preference sensitive

https://gerrit.wikimedia.org/r/293030

aaron triaged this task as High priority.Jun 6 2016, 10:54 PM

Change 293050 had a related patch set uploaded (by Aaron Schulz):
Flag internal page retrieve/save cycles with EDIT_INTERNAL

https://gerrit.wikimedia.org/r/293050

Change 293341 had a related patch set uploaded (by Aaron Schulz):
Flag internal page retrieve/save cycles with EDIT_INTERNAL

https://gerrit.wikimedia.org/r/293341

Change 293359 had a related patch set uploaded (by Aaron Schulz):
Perform edit stashing for ?undo and ?oldid reverts

https://gerrit.wikimedia.org/r/293359

Change 293050 merged by jenkins-bot:
Flag internal page retrieve/save cycles with EDIT_INTERNAL

https://gerrit.wikimedia.org/r/293050

Change 293341 merged by jenkins-bot:
Flag internal page retrieve/save cycles with EDIT_INTERNAL

https://gerrit.wikimedia.org/r/293341

Change 293683 had a related patch set uploaded (by Aaron Schulz):
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/293683

Change 293880 had a related patch set uploaded (by Aaron Schulz):
Perform edit stashing for ?undo and ?oldid reverts

https://gerrit.wikimedia.org/r/293880

Change 293359 merged by jenkins-bot:
Perform edit stashing for ?undo and ?oldid reverts

https://gerrit.wikimedia.org/r/293359

Change 293963 had a related patch set uploaded (by Aaron Schulz):
Perform edit stashing for ?undo and ?oldid reverts

https://gerrit.wikimedia.org/r/293963

Change 293963 merged by jenkins-bot:
Perform edit stashing for ?undo and ?oldid reverts

https://gerrit.wikimedia.org/r/293963

Change 294294 had a related patch set uploaded (by Aaron Schulz):
Perform edit stashing when the edit preview or diff form is requested

https://gerrit.wikimedia.org/r/294294

Change 294294 merged by jenkins-bot:
Perform edit stashing when the edit preview or diff form is requested

https://gerrit.wikimedia.org/r/294294

Change 293683 merged by jenkins-bot:
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/293683

Change 294369 had a related patch set uploaded (by Aaron Schulz):
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/294369

Change 294369 merged by jenkins-bot:
Improvements to {{REVISIONUSER}} handling

https://gerrit.wikimedia.org/r/294369

Change 294382 had a related patch set uploaded (by Aaron Schulz):
Perform edit stashing when the edit preview or diff form is requested

https://gerrit.wikimedia.org/r/294382

Change 294382 merged by jenkins-bot:
Perform edit stashing when the edit preview or diff form is requested

https://gerrit.wikimedia.org/r/294382

Change 294414 had a related patch set uploaded (by Aaron Schulz):
Use a low TTL for parser output when special pages are included

https://gerrit.wikimedia.org/r/294414

Change 294415 had a related patch set uploaded (by Aaron Schulz):
Use a low TTL for parser output when special pages are included

https://gerrit.wikimedia.org/r/294415

Change 294414 merged by jenkins-bot:
Use a low TTL for parser output when special pages are included

https://gerrit.wikimedia.org/r/294414

Change 294416 had a related patch set uploaded (by Aaron Schulz):
Use a low TTL for parser output when special pages are included

https://gerrit.wikimedia.org/r/294416

Change 294416 merged by jenkins-bot:
Use a low TTL for parser output when special pages are included

https://gerrit.wikimedia.org/r/294416

Change 294415 merged by jenkins-bot:
Use a low TTL for parser output when special pages are included

https://gerrit.wikimedia.org/r/294415

aaron closed this task as Resolved.Jun 17 2016, 2:43 AM

<<+channel:StashEdit +wiki:enwiki +message:*no_ttl*>> is nearly empty. The cause of stash skipping is var_revision almost entirely. Fixing that could get us to ~2 hits/sec

Aside from that, between the lack of android/ios and mobile site stashing and some JS tools doing reverts, I think we have plenty to go on. All of these have subtasks.

Change 295023 had a related patch set uploaded (by Aaron Schulz):
Improve edit stashing when vary-revision is used

https://gerrit.wikimedia.org/r/295023

Change 295024 had a related patch set uploaded (by Aaron Schulz):
Improve edit stashing when vary-revision is used

https://gerrit.wikimedia.org/r/295024

Change 295024 merged by jenkins-bot:
Improve edit stashing when vary-revision is used

https://gerrit.wikimedia.org/r/295024

Change 295023 merged by jenkins-bot:
Improve edit stashing when vary-revision is used

https://gerrit.wikimedia.org/r/295023

Change 293880 abandoned by Aaron Schulz:
[WIP] Backend edit stashing for ?undo and ?oldid reverts

Reason:
Went with front-end patch

https://gerrit.wikimedia.org/r/293880