Page MenuHomePhabricator

In cross-wiki notification bundle, "mark as read" secondary link doesn't do anything
Closed, ResolvedPublic

Description

The "Mark as read" secondary link, for a cross-wiki notification bundle, doesn't do anything.

(Not to be confused with the "Mark all as read" button at the top of the flyout, which purposefully doesn't clear the cross-wiki notification bundle from the flyout, per T121931: "Mark all as read" button completely ignores cross-wiki notification group item)

Details

Related Gerrit Patches:

Event Timeline

Quiddity created this task.Jun 2 2016, 7:54 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 2 2016, 7:54 PM

The same in betalabs - oo-ui-iconElement-icon oo-ui-icon-ellipsis button does not work.

Change 292602 had a related patch set uploaded (by Mooeypoo):
Listen to 'mark as read' secondary link in xwiki bundles

https://gerrit.wikimedia.org/r/292602

Mooeypoo claimed this task.Jun 3 2016, 6:48 PM
Mooeypoo moved this task from Untriaged to Needs Review on the Collab-Team-2016-Apr-Jun-Q4 board.

Change 292602 merged by jenkins-bot:
Listen to 'mark as read' secondary link in xwiki bundles

https://gerrit.wikimedia.org/r/292602

Checked the fix in betalabs - 'Mark as read' works as intended: other wikis Alerts/Messages will be marked as Read after clicking on 'Mark as read' dotdotdot menu.

jmatazzoni closed this task as Resolved.Jun 6 2016, 5:10 PM