Page MenuHomePhabricator

[betalabs] Special:Notifications page has wrong sorting order after messages are 'Marked as unread'
Closed, ResolvedPublic

Description

Since we have pagination now on Special: Notifications page, the issue is filed separately from T135307: Special page: Requested notifications are in wrong order .

  1. On Special:Notifications page with several pages of notifications - click on 'Read' tab and mark some messages from different dates (preferably from from different dates).
  2. Then, click on 'Unread' - and also mark some notifications as read.
  3. Go to 'All' tab - the chronological order is broken - sometime on the first page, sometime on the second page.

Very often the chronological order on the first page is preserved - say, for e.g. displaying from notifications from May to February, but the second page may start with notifications dated by April, for example.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 2 2016, 9:08 PM
Quiddity renamed this task from [betalabs] Special:Notificaitons page has wrong sorting order after messages are 'Marked as unread' to [betalabs] Special:Notifications page has wrong sorting order after messages are 'Marked as unread' .Jun 6 2016, 9:39 PM

I can't reproduce this anymore... I tried over and over, and it doesn't happen for me on master.

Can you double-check if this still happens? If so, is there any other condition I should try? Does it happen with items that are part of a bundle, or general items?

I've tried it, and managed to reproduce it in production.

Page 1:

Page 2:

From @Mooeypoo observation (confirmed by me) - the issue has nothing to do with marking 'Read' and 'Unread'. Reproducible just by going to Special:Notifications with at least to pages - the chronological order will be broken between first and second pages.

Change 297924 had a related patch set uploaded (by Mooeypoo):
Only fetch 'unreadfirst' for the Popup, not Special:Notifications

https://gerrit.wikimedia.org/r/297924

Change 297924 merged by jenkins-bot:
Only fetch 'unreadfirst' for the Popup, not Special:Notifications

https://gerrit.wikimedia.org/r/297924

Etonkovidova updated the task description. (Show Details)Jul 8 2016, 6:04 PM

Checked the fix in betalabs - no issues with pagination sorting.

jmatazzoni closed this task as Resolved.Jul 8 2016, 6:20 PM