Page MenuHomePhabricator

Add alt text for math SVG images
Closed, ResolvedPublic

Description

After switching back to regular img tags as fallback elements, we should also deliver the alt text.
Even though there are more advanced ways of using MathML for accessiblilty http://mathml-association.org/announcement/2016/05/31/wikipedia.html adding the alt text does not harm.

Details

Related Gerrit Patches:
mediawiki/extensions/Math : masterAdd alt tag for SVG image

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 3 2016, 7:19 AM
Physikerwelt triaged this task as Medium priority.Jun 3 2016, 2:37 PM

Change 292952 had a related patch set uploaded (by Physikerwelt):
Add alt tag for SVG image

https://gerrit.wikimedia.org/r/292952

Change 292952 merged by jenkins-bot:
Add alt tag for SVG image

https://gerrit.wikimedia.org/r/292952

Jaifroid reopened this task as Open.Jun 23 2019, 5:01 PM
Jaifroid added a subscriber: Jaifroid.

This seems to be broken again, as per https://phabricator.wikimedia.org/T209277 .

@Jaifroid: Please provide a test case for your statement. I see an alt tag on e.g. https://en.wikipedia.org/wiki/Mathematics#Quantity ...

Jaifroid closed this task as Resolved.Jul 2 2019, 10:25 AM

Apologies @Aklapper, the reported issue relates to Parsoid. I think I posted this in the wrong place.

Lpd-Lbr added a subscriber: Lpd-Lbr.EditedSep 17 2019, 5:08 PM

I believe that this change added behaviour that runs counter to the documentation in https://meta.wikimedia.org/wiki/Help:Displaying_a_formula#Rendering

The expected behaviour as documented is to display an alt text if any is given. However, it seems to be ignored (See T233121: alt tag in math environment seems to get ignored ).