Page MenuHomePhabricator

ext.wikimediaEvents.deprecate.js during debug at nowiki
Closed, ResolvedPublic

Description

Given that I log in
And I turn off all local user scripts
And all global scripts
And all gadgets
When I load https://no.wikipedia.org/wiki/Portal:Forside?debug=true
Then I got a 404 "unknown file path" on https://no.wikipedia.org/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.deprecate.js?

I did not spot the bug last night during other debugging.

I can not spot anything obvious that is broken.

Not sure how this should be tagged.

Event Timeline

jeblad created this task.Jun 3 2016, 7:58 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 3 2016, 7:58 AM
jeblad updated the task description. (Show Details)Jun 3 2016, 7:59 AM
Krenair added subscribers: Krinkle, Krenair.

It should be using 'extensions' in the URL instead of 'skins'

Krinkle updated the task description. (Show Details)Jun 3 2016, 7:04 PM

I can reproduce this. Note that aside from the skins directory being used instead of extensions, the query string is also empty. Which means ResourceLoader was unable to locate the file on disk.

] );mw.loader.implement( "ext.wikimediaEvents", [
    "/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.statsd.js?",
    "/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.rlfeature.js?",
    "/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.searchSatisfaction.js?",
    "/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.search.js?",
    "/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.geoFeatures.js?"
mw.loader.implement( "ext.wikimediaEvents.loggedin", [
    "/w/skins/WikimediaEvents/modules/ext.wikimediaEvents.deprecate.js?"
] );

Caused by rEWMV8aefdcaf416b: Improve extension.json.

Change 292609 had a related patch set uploaded (by Krinkle):
Fix broken remoteBasePath (extensions, not skins)

https://gerrit.wikimedia.org/r/292609

Krinkle claimed this task.Jun 3 2016, 7:24 PM
Krinkle triaged this task as Normal priority.

Change 292611 had a related patch set uploaded (by Krinkle):
Fix broken remoteBasePath (extensions, not skins)

https://gerrit.wikimedia.org/r/292611

Change 292609 merged by jenkins-bot:
Fix broken remoteBasePath (extensions, not skins)

https://gerrit.wikimedia.org/r/292609

Change 292611 merged by jenkins-bot:
Fix broken remoteBasePath (extensions, not skins)

https://gerrit.wikimedia.org/r/292611

Mentioned in SAL [2016-06-03T19:37:56Z] <krinkle@tin> Synchronized php-1.28.0-wmf.4/extensions/WikimediaEvents/extension.json: T136920 (duration: 00m 28s)

jeblad added a comment.Jun 3 2016, 8:02 PM

That was fast! =D

Krinkle closed this task as Resolved.Jun 6 2016, 4:16 PM