Page MenuHomePhabricator

"Remember my last editor" seems to behave inconsistently?
Closed, InvalidPublic

Description

(I had reported this previously as well, but it probably deserves a separate task.)

At zh-yue, setting is Remember my last editor, I launch VE, then start hitting Special:Random.
Click on Edit, VE launches, hit Special:Random again (without closing VE).
Sometimes it takes a few attempts, sometimes it take multiple tries, but in the end I'll always land on some article which will show me "Edit source" rather than Edit (and I obviously haven't switched).
I do not see a warning message.
The above is how I manage to reproduce the behaviour. I have no idea if this also occurs while editing more "regularly".

As of July 2017, looks like the same thing, or a very similar one, is reported at https://www.mediawiki.org/wiki/Topic:Ttle85qn8vj8o9ml for pa.wp .
However, because not many details are provided, and I can't reproduce any of that, I don't know that we can diagnose anything here.

Related Objects

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 7 2016, 5:10 PM
Jdforrester-WMF changed the task status from Open to Stalled.Jul 19 2016, 7:23 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

I think we may have fixed this, but I'm not sure I can point to how, so marking this as "Stalled" for now.

Liuxinyu970226 added a project: TestMe.EditedFeb 19 2017, 7:52 AM
Liuxinyu970226 added a subscriber: Liuxinyu970226.

I think we may have fixed this, but I'm not sure I can point to how, so marking this as "Stalled" for now.

And in my recently test it really reproduced (sorry, only once and kept for 2 seconds, so I haven't any screenshots), so perhaps this issue is reproduceable only for some users.

Maybe this can also lead to T30441 resolving (more quickly?), because otherwise I can't fancy that what's another FIXME way

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptFeb 19 2017, 7:52 AM
Elitre renamed this task from "Remember my last editor" seems to behave inconsistently, at least at https://zh-yue.wikipedia.org/ to "Remember my last editor" seems to behave inconsistently?.Jul 6 2017, 7:15 PM
Elitre updated the task description. (Show Details)
Elitre updated the task description. (Show Details)
Deskana closed this task as Invalid.Aug 27 2018, 1:40 PM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptAug 27 2018, 1:40 PM