Page MenuHomePhabricator

Inform communities about planned outages caused by the server switch (April&May 2017)
Closed, ResolvedPublic

Description

The server change may cause the sites to be in $wgReadOnly mode for 15 to 30 minutes. We should communicate this to editors in advance, using User-notice and other methods.

Overall plan

Do what worked for T129387 in April and May 2016, including:

  • Multiple announcements in Tech News
  • Simple explanation at https://meta.wikimedia.org/wiki/Tech/Server_switch_2016 to be sent via MassMessage to (nearly) all wikis
  • Last-minute warnings via CentralNotice about the impending site outage.
  • Post on some mailing lists (e.g., wikitech-l, maybe tech-ambassadors@?) and/or IRC.
  • etc.

Also:

  • Earlier warning to Outreach/Education people, so that they can avoid scheduling workshops on the likely dates.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 8 2016, 3:04 PM
Whatamidoing-WMF triaged this task as Medium priority.Jun 30 2016, 3:45 PM
Qgil added a subscriber: Qgil.Jul 7 2016, 9:23 PM

In which month do you expect to start working on this task?

Whatamidoing-WMF added a comment.EditedJul 8 2016, 12:19 AM

September. It will likely be finished in late November.

Whatamidoing-WMF renamed this task from Inform communities about planned outages caused by the server switch (October or November 2016) to Inform communities about planned outages caused by the server switch (February 2017?).Sep 23 2016, 6:17 PM
Elitre added a subscriber: Elitre.Dec 14 2016, 4:10 PM
Whatamidoing-WMF renamed this task from Inform communities about planned outages caused by the server switch (February 2017?) to Inform communities about planned outages caused by the server switch (April 2017?).Jan 23 2017, 8:06 PM
Elitre renamed this task from Inform communities about planned outages caused by the server switch (April 2017?) to Inform communities about planned outages caused by the server switch (April&May 2017).Apr 13 2017, 9:05 PM
Elitre awarded a token.
Zppix added a subscriber: Quiddity.EditedApr 13 2017, 9:07 PM

Wikipedia-l was already informed by myself, I know @Quiddity has emailed several other mailing lists about this aswell, it was also added in the upcoming Tech News.

@Jseddon will be handling the CentralNotices.

I still need to make a list of people who can hang out on IRC to answer any questions from editors and/or make themselves available to Faidon, if he has any information that he wants shared with the communities.

@Whatamidoing-WMF I'm able to help in IRC

Whatamidoing-WMF added a comment.EditedApr 13 2017, 11:35 PM

Thanks, Zppix. The switch starts at 14:00 UTC, which is 7:00 PDT (my timezone). Around 13:00 UTC, Elitre's planning to remind these three IRC channels:

#wikimedia-stewards
#wikipedia
#wikipedia-en

that this is happening, so that the regulars won't be surprised by any questions. (No matter how many announcements you've seen, it's still easy to forget when it's happening.) Please feel free to post this to your own favorite channels as well; if you'd like to make all of the announcements, then just talk to Elitre.

The main things to know are:

  • The wikis will probably be in read-only mode for about 20 to 30 minutes.
    • If an editor has started an edit, and now can't save it, then the editor can try to save after the wikis are back. It should work (but you might want to make a backup copy of your changes, just in case it doesn't).
    • Last time, it took a while for Special:RecentChanges to wake up. I don't know if that will happen again, but if it does, then it's a bit annoying but not an emergency. I posted instructions at enwiki's WP:AN on how to find any missing edits.
  • Users with unexpected problems can report those in the #wikimedia-tech IRC channel, or they can file Phab tasks with the codfw-rollout tag. #wikimedia-operations (the usual place to find the Ops folks) is supposed to be moderated until it's over, so you won't be able to report problems there.
  • If you hear about a problem that sounds serious, then tell Faidon via IRC. His user page says that his IRC nick is paravoid. And if Faidon asks for your help, then please try to help him.
  • This is happening twice, two weeks apart. Please remind people about that fact on 19 April.
Zppix added a comment.Apr 14 2017, 5:08 PM

@Whatamidoing-WMF Okay thank you sherry.

jcrespo added a subscriber: jcrespo.May 4 2017, 1:47 PM

I think this is resolved.

Qgil awarded a token.May 4 2017, 2:01 PM
Whatamidoing-WMF closed this task as Resolved.May 4 2017, 5:17 PM

Everything's done except collecting ideas on how to improve the process for next time (which never really stops).

jcrespo added a comment.EditedMay 4 2017, 5:36 PM

Related, we took into account user feedback on list to improve the message shown to editors at T164177.

Elitre added a comment.May 5 2017, 4:32 PM

I was considering rescinding the token to give it again!
Thanks everyone.
/me throws confetti on Ops and PrincessInResidence