Page MenuHomePhabricator

Title blacklist warning does not account for <autoconfirmed> restriction in certain circumstances
Closed, ResolvedPublic

Description

Problem: when the title blacklist is used with the <autoconfirmed> option, the warning message displayed to admin users on editing a matching title claims it is restricted to admins (and template editors).

Steps to reproduce:
1: Log in to an admin account (this example uses English Wikipedia)
2: Visit https://en.wikipedia.org/w/index.php?title=Wikipedia:Today%27s_featured_article/January_23,_2016&action=edit or https://en.wikipedia.org/w/index.php?title=Morgan_is_a_moron&action=edit&redlink=1
3: Observe the banner message "This page can only be edited by administrators and template editors"
4: Log in to an autoconfirmed but not admin account
5: Visit the same pages. No banner is displayed and editing is allowed.

Details

Related Gerrit Patches:
mediawiki/extensions/TitleBlacklist : masterDon't show blacklist warning for autoconfirmed protection

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 8 2016, 10:32 PM

As to how to solve this, either we make it so the admin does not see a warning (making it consistent with non-admin autoconfirmed accounts) or we make the warning say "restricted to autoconfirmed users". I don't see the utility in having a warning when the page is restricted to autoconfirmed only, so I suggest just removing it.

BethNaught updated the task description. (Show Details)Jun 8 2016, 10:54 PM

I don't see the utility in having a warning when the page is restricted to autoconfirmed only

I disagree. After all, we have such a warning for regular semi-protection.

Jackmcbarn added a subscriber: ori.Jun 9 2016, 11:29 PM

Hmm, apparently this was intentionally done by @ori in rETBLa05d0abed95481de9009050c0e0a759900708d4a. Adding him for comment.

Change 294419 had a related patch set uploaded (by Jackmcbarn):
Don't show blacklist warning for autoconfirmed protection

https://gerrit.wikimedia.org/r/294419

Change 294419 merged by jenkins-bot:
Don't show blacklist warning for autoconfirmed protection

https://gerrit.wikimedia.org/r/294419

ori assigned this task to Jackmcbarn.Jun 15 2016, 5:55 AM

My intent was to avoid loading and scanning the blacklist in cases where doing so would be irrelevant to spam-fighting. @BethNaught's proposed solution seems like the right one to me, and I guess @Jackmcbarn agreed because he went ahead and implemented it (thanks).

ori closed this task as Resolved.Jun 15 2016, 5:56 AM