Page MenuHomePhabricator

MT engine failure cause fallback translation not getting saved
Closed, ResolvedPublic

Description

When an MT request to cxserver fails, we fallback to source translation.
The reason for failure can be anything - very large paragraph, network
timeout, failures from the MT engines. But when the fallback to
copy-source happens, what get saved to database is the placeholder div.

This was because the section reference is not updated in the failure
handler of MT request and holding old section value.

Steps to reproduce:

(if you have local cxserver, this is more easy since you can simulate
MT engine failure)
Translate Hideo Hosono from en to fr. The 'Selected publications' section
is too long for Yandex to translate and will fallback to source. You
will also see translation saved status. Reload the page by pressing F5
or CTRL+R. This secion will not get restored and you will see a placeholder
with in progress indicator. Additionally you may inspect the translation
storage for the section too.

Event Timeline

santhosh created this task.Jun 10 2016, 7:17 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 10 2016, 7:17 AM
santhosh claimed this task.Jun 10 2016, 7:17 AM
santhosh triaged this task as High priority.

Change 293684 had a related patch set uploaded (by Santhosh):
MT engine failure cause fallback translation not getting saved

https://gerrit.wikimedia.org/r/293684

Change 293684 merged by Nikerabbit:
MT engine failure cause fallback translation not getting saved

https://gerrit.wikimedia.org/r/293684

Arrbee moved this task from QA to Done on the Language-Q4-2016-Sprint 4 board.Jun 14 2016, 7:54 AM
Arrbee closed this task as Resolved.