Page MenuHomePhabricator

Incubator extension doesn't prevent editing in Category & Category talk for created wikis
Closed, ResolvedPublic

Description

The Incubator extension doesn't prevent editing in Category & Category talk for prefixed pages which belong to an existing subdomain (as it does in the other NSes).

Event Timeline

Restricted Application added subscribers: Zppix, Hydriz, Aklapper. · View Herald TranscriptJun 10 2016, 4:42 PM

I can't reproduce this issue (see https://incubator.wikimedia.org/wiki/Category:Wp/jam/Test). Can you provide links showing this problem?

Hydriz triaged this task as Medium priority.Jun 11 2016, 4:30 AM

Very strange. I don't remember on which page I noticed it yesterday (I deleted 3 ex-test-projects, in one of them I saw it). Restoring a page also can't reproduce it.
We can see whether it occurs again when a new subdomain is created.

That's because you have the editinterface right. The Incubator extension allows users with the editinterface right to edit any main pages for each test wiki. Try it when logged out and you would not be able to edit the page. Do you suggest that these pages should not be edited?

I see you are right.
I suggest so, but if it only concerns the main category page and is limited to editinterface people, it is basically a non-issue. You can close this if you want.

Hydriz closed this task as Resolved.Apr 9 2017, 2:26 PM
Hydriz claimed this task.

I would want to keep these pages editable to people with editinterface rights, so closing this task.