Page MenuHomePhabricator

Day names are in English and not translatables on Special:Notifications
Closed, ResolvedPublic

Description

"Včera" (yesterday) is localized. However, I would expect "Pondělí" instead of "Monday". Wiki: cswiki; interface language: Czech (cs).

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 11 2016, 1:00 PM

What's the link to reproduce the problem?

Mattflaschen-WMF renamed this task from Day names are not in my language to Day names are not in Czech.Jun 11 2016, 8:46 PM

That not only for Czech: they are in English for everyone.

Trizek-WMF renamed this task from Day names are not in Czech to Day names are in English and not translatables on Special:Notifications.Jun 13 2016, 9:29 AM
Trizek-WMF triaged this task as High priority.
Catrope raised the priority of this task from High to Unbreak Now!.Jun 13 2016, 11:15 AM
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptJun 13 2016, 11:15 AM

Change 294048 had a related patch set uploaded (by Catrope):
Use localized weekdays on Special:Notifications

https://gerrit.wikimedia.org/r/294048

Change 294048 merged by jenkins-bot:
Use localized weekdays on Special:Notifications

https://gerrit.wikimedia.org/r/294048

Change 294054 had a related patch set uploaded (by Catrope):
Use localized weekdays on Special:Notifications

https://gerrit.wikimedia.org/r/294054

Fix scheduled for the SWAT at 15:00 UTC.

Change 294054 merged by jenkins-bot:
Use localized weekdays on Special:Notifications

https://gerrit.wikimedia.org/r/294054

I superintended deployment just now; this looks fixed to me, but I'll leave to @Etonkovidova to close.

Etonkovidova added a comment.EditedJun 15 2016, 4:19 PM

Checked in testwiki (with uselang=cs) and frwiki

@Trizek-WMF - what do you think about capitalization for date names (e.g. 'vendredi')?
Btw, viewing via uselang=qqx will not display weekday translation tags (it's a correct behavior).

@Trizek-WMF - what do you think about capitalization for date names (e.g. 'vendredi')?

Day names should be capitalized. I think that applies to all Roman languages.
At least, in French, if day names are at the beginning of a sentence they have to capitalized; when they are included into the sentence, they are not capitalized anymore (unlike it is in English).

@Mooeypoo will put this to the translation team.

I could use a language expert's opinion here @Amire80 :

The problem is this: We are using pre-existing day name translations in our Special:Notifications page to separate groups of notification by days. Some of those messages, in some languages, are not capitalized - which looks weird to us. However, I think that capitalization is probably a language dependent issue, right? I assume not all languages capitalize day names at all.

However to that, though, is it possible that the translations we're using were meant to be used in the middle of a sentence, so their capitalization wasn't taken into account as if they're their own sentence?

So, bottom line -- is it okay for us to continue using these messages for the Special:Notifications case, each day displayed as a title to a notification group -- or do we need to create a series of new messages and specifically state that they are both day names and titles for a group?

@Jdforrester-WMF suggests using CSS text-transform to uppercase the first letter.

@Jdforrester-WMF suggests using CSS text-transform to uppercase the first letter.

Is this something we want to do though? We said that there are several languages where capitalization of day names make no sense?

DecodeD renamed this task from Day names are in English and not translatables on Special:Notifications to WHO ARE YOU.Jul 1 2016, 6:53 PM
DecodeD removed Mooeypoo as the assignee of this task.
DecodeD updated the task description. (Show Details)
Danny_B renamed this task from WHO ARE YOU to Day names are in English and not translatables on Special:Notifications.Jul 1 2016, 7:01 PM

@Mooeypoo, I don't understand the problem. These are essentially titles--as you suggest. So the capitalization rules for specific languages or words really shouldn't matter. Am I missing something? Is there a reason I can't move this out of Blocked?

@Mooeypoo, I don't understand the problem. These are essentially titles--as you suggest. So the capitalization rules for specific languages or words really shouldn't matter. Am I missing something? Is there a reason I can't move this out of Blocked?

I may have misunderstood, but in our last conversation about this, it was pointed out that capitalizing day names and dates is not the custom for all languages - that's why I wanted to check this.

I can add the css rule to automatically capitalize all those titles, if we decide that's what we wanted to do - but it wasn't clear whether this would fix this bug or "just" shift it to look weird in other languages. I was waiting for an answer from the language team.

@Amire80, can you please have a look at this? If we treat the day names in the screenshot below as titles and capitalize the first letter, is it OK for that to trump whatever the particular rules of any language might be? Or do you have a better suggestion?

Don't capitalize. Let the translators do it.

I am not sure that this is the case hrre, but if a word can appear both in the beginning and the middle of a sentence, it should be in different messages anyway.

if a word can appear both in the beginning and the middle of a sentence

Thanks @Amire80. That's not the case here.

The question here is, if the word giovedi (Thurs) is not capitalized in Italian, that's fine. But when we list it at the beginning of a line over a group of messages, as a title for that group, it can be capitalized, right?

I presume this happens programmatically, rather than in the translation, but I'm not sure. @Mooeypoo, I'm trying to help resolve this but I'm afraid I don't understand what the sticking point is.

It shouldn't happen programmatically. Most alphabets don't have case at all, and in those that do the rules differ. It is better left to translators. Message that is used as a title should be separate, and say that it's a title in its qqq documentation.

@Mooeypoo, I'm moving this to In Development. Let me know if that doesn't answer your question.

It shouldn't happen programmatically. Most alphabets don't have case at all, and in those that do the rules differ. It is better left to translators. Message that is used as a title should be separate, and say that it's a title in its qqq documentation.

Is this still true for dates, though? These are dates we are getting from MomentJS... Aren't they supposed to be titles already?

We are working with day names that come from MomentJS and are meant to be dates. Given that, I would expect them to be ready-made for the date-title we use them for, but maybe they're not.

So we have two options:

  1. Leave things as-is (because momentJS is the way dates are front-end, consistently, in MW, and if we change translation it should change in all of the instances anyways)
  2. For day-names, not use MomentJS, and instead create our own i18n messages for day names, stating clearly that they are titles.

Honestly, I'm for #1. I think this is a consistency issue, and we're using moment - a library that's meant for that - so if there's anything to fix, it should be there.

Then again, I'm not clear if our usage is different than other usages of the library in MW. If so, we could go with #2, it would just mean another potential layer of duplication of messages and waiting for translations.

Quiddity lowered the priority of this task from Unbreak Now! to Normal.Jul 13 2016, 8:45 PM
Quiddity added a subscriber: Quiddity.

Lowering priority, now that the main issue is fixed, and we're just working out nuances.

Change 298873 had a related patch set uploaded (by Mooeypoo):
Capitalize title dates in Special:Notifications

https://gerrit.wikimedia.org/r/298873

We can't figure out how best to resolve this, so in order to stop spending donor money on fruitless debate, we have made a decision to use the standard javascript translations and css to capitalize the day names in this position, where they function as titles. (If this is the wrong decision, we will be happy to reverse course when we hear from the community.)

Change 298873 merged by jenkins-bot:
Capitalize title dates in Special:Notifications

https://gerrit.wikimedia.org/r/298873

Checked in betalabs

  1. The screenshot for uselang=cs (the lang for which the issue was filed): "Pondělí"(Monday) is displayed in Czech. It's capitalized.

Comparing to Russian lang - the day of the week (the first word) is capitalized and months names are not capitalized which actually follows Russian grammar rules for titles' capitalizations.

  1. I agree with @jmatazzoni and @Mooeypoo, as in

Leave things as-is (because momentJS is the way dates are front-end, consistently, in MW, and if we change translation it should change in all of the instances anyways).

Also, I agree with @Amire80's statement that there are many languages that

  • do not use capitalization at all
  • have different rules for general capitalization
  • have different rules for capitalization in titles

And, of course, capitalization of weekday and month names depends on the date format that a specific wiki uses.

To summarize: the filed issue is resolved; other issues with capitalization should be solved on case per case base.

jmatazzoni closed this task as Resolved.Jul 18 2016, 5:12 PM