Page MenuHomePhabricator

Unblock stuck global renames at mediawiki.org
Closed, ResolvedPublic

Description

Global Rename Progress shows a large numbers of renames stuck "In progress" at mediawiki.org. Having checked site stats, it returns 0 jobs in the queue:

{
    "batchcomplete": "",
    "servedby": "mw1193",
    "curtimestamp": "2016-06-12T08:50:00Z",
    "query": {
        "statistics": {
            "pages": 493377,
            "articles": 32832,
            "edits": 2215236,
            "images": 3026,
            "users": 6556209,
            "activeusers": 1298,
            "admins": 183,
            "jobs": 0,
            "queued-massmessages": 0
        }
    }
}

Can these be unblocked? Thanks.

Event Timeline

Restricted Application added subscribers: Zppix, Steinsplitter, Aklapper. · View Herald Transcript
Restricted Application added a subscriber: JEumerus. · View Herald TranscriptJun 12 2016, 8:53 AM

Nuevo Paso is blocked at more than one site and might need further work.

MarcoAurelio triaged this task as Unbreak Now! priority.Jun 12 2016, 5:34 PM

Since those users can't log-in to their accounts until renames are finished. If not unbreak, at least high priority.

Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptJun 12 2016, 5:34 PM
Tgr closed this task as Resolved.Jun 13 2016, 8:11 PM
Tgr assigned this task to Anomie.
Tgr added a subscriber: Tgr.

Should be fixed, per T135656#2376510.

Anomie closed this task as Resolved.Jun 14 2016, 3:14 PM

That one isn't stuck at mediawiki.org, it's stuck on 103 other wikis and likely for a different reason than the ones at mediawiki.org.

Tgr added a comment.Jun 14 2016, 3:26 PM

There is a "Could not find local user data" error (T119736) for Nuevo_Paso in the logs which matches the time of the rename attempts. Not sure if that is the cause or the consequence of the renames getting stuck (or not related at all).

Restricted Application added a subscriber: Jay8g. · View Herald TranscriptSep 19 2016, 8:43 PM
MarcoAurelio moved this task from Backlog to Closed on the GlobalRename board.Oct 11 2016, 1:12 PM