Page MenuHomePhabricator

Cannot scroll the page using up or down arrow when focus is in an editing area
Closed, ResolvedPublic

Description

When the focus is in a translation section(editable), pressing up or down arrow will not make the page scroll. Instead the cursor will go up and down and stop and the section boundary(for example - a paragraph)

This is because the every section is individual contenteditables. Special key handling may require to get the focus to the section above or below.

Reported at https://www.mediawiki.org/wiki/Topic:T5uoxycm1mt6fku1

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 14 2016, 10:41 AM

I proposed supporting arrows to move across sections at T109056#1872607.

I think the expected behaviour should be:

  • When reaching the end/beginning of a section, pressing down/up keys should bring the editing cursor to the next/previous block.
  • If the previous/next block has not been added to the translation, the block should become highlighted for the user to be able to (a) add the translation by pressing enter, or (b) keep moving with the arrows to other blocks.

I agree with Pau—this is simple and intuitive.

"New functionality", because this may require significant coding effort (and it's great if I'm overestimating), and because it is a bit of a departure from the strong focus on isolated paragraphs that we had till now.

Amire80 triaged this task as Medium priority.Jun 19 2016, 11:02 AM
Amire80 moved this task from Needs Triage to Bugs on the ContentTranslation board.
Arrbee moved this task from Bugs to Enhancements on the ContentTranslation board.Jun 22 2018, 1:41 PM
Etonkovidova closed this task as Resolved.May 27 2019, 2:49 PM
Etonkovidova claimed this task.
Etonkovidova added a subscriber: Etonkovidova.

Checked in wmf.6 - up-down arrow buttons allow users to scroll moving between (and within) translated paragraphs. User can navigate up and down a page even without translated paragraphs.