Page MenuHomePhabricator

wmbot command for@seen should ignore trailing spaces after user name
Closed, ResolvedPublic

Description

Some clients will add a trailing space when autocompleting nicks. wm-bot does not strip the trailing spaces, and as such the command returns 'I have never seen <nick>' which can be a very annoying problem to diagnose. It would be helpful if wm-bot stripped any trailing spaces after the nick, because IRC nicks cannot have spaces in them.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 16 2016, 11:27 AM
tom29739 updated the task description. (Show Details)Jun 16 2016, 11:30 AM
Poyekhali updated the task description. (Show Details)Jun 16 2016, 11:38 AM
Poyekhali updated the task description. (Show Details)Jun 16 2016, 11:55 AM

@seen works for me with hexchat

I think that it is an autocomplete issue adding an additional space

Billinghurst closed this task as Invalid.Jun 16 2016, 12:26 PM
Billinghurst renamed this task from tom29739 cannot use the @seen command at #wm-bot to wmbot command for@seen should ignore trailing spaces after user name.Jun 16 2016, 12:29 PM
Billinghurst reopened this task as Open.
tom29739 updated the task description. (Show Details)Jun 16 2016, 12:35 PM
Poyekhali triaged this task as Normal priority.Jun 17 2016, 10:41 AM
Petrb closed this task as Resolved.May 19 2017, 5:27 PM

I think it works already, I can't reproduce this