Unknown dependency: schema.geoFeatures with WikiMiniAtlas - Map does not load
Closed, ResolvedPublic

Description

Press the Earth-globe-icon in the "camera location" on https://commons.wikimedia.org/wiki/File:Ziziphus_joazeiro_Mart._-_Flickr_-_Alex_Popovkin,_Bahia,_Brazil_(9).jpg

The map won't load, and the following appears in the console:

Uncaught Error: Unknown dependency: schema.geoFeatures                             load.php:160

and when zooming the map out the following appears in the console:

Failed to load resource: the server responded with a status of 404 (Not Found)            https://wma.wmflabs.org/tiles/mapnik/12/6965/tile_6965_21976.png
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 17 2016, 12:32 PM
Restricted Application added a project: Discovery. · View Herald TranscriptJun 17 2016, 12:32 PM
Restricted Application added subscribers: Poyekhali, Steinsplitter. · View Herald TranscriptJun 17 2016, 12:33 PM
Aklapper renamed this task from Unknown dependency: schema.geoFeatures with WikiMiniAtlas to Unknown dependency: schema.geoFeatures with WikiMiniAtlas - Map does not load.Jun 17 2016, 12:43 PM

Hmm, I have no idea what schema.geoFeatures is. I don't think I added that. In Chrome the map still loads though.

MaxSem added a comment.EditedJun 17 2016, 5:38 PM

(wrong bug)

It would really be nice I somebody kept me in the loop if analytics are done to study the use of WMA. If I only find out about it because it breaks the WMA for some users that kind of... sucks.

Change 294950 had a related patch set uploaded (by MaxSem):
Fix schema name

https://gerrit.wikimedia.org/r/294950

Change 294950 merged by jenkins-bot:
Fix schema name

https://gerrit.wikimedia.org/r/294950

Change 294958 had a related patch set uploaded (by MaxSem):
Fix schema name

https://gerrit.wikimedia.org/r/294958

Change 294958 merged by jenkins-bot:
Fix schema name

https://gerrit.wikimedia.org/r/294958

https://commons.wikimedia.org/w/index.php?title=File:Ziziphus_joazeiro_Mart._-_Flickr_-_Alex_Popovkin,_Bahia,_Brazil_(9).jpg&debug=1

Error: Unknown dependency: schema.geoFeatures

sortDependencies()load.php:11596
resolve/<()load.php:11658
.each()load.php:384
resolve()load.php:11657
mw.loader.using()load.php:12409
doTrack()ext.wikimediaEvents.geoFeatures.js:62
<anonymous>ext.wikimediaEvents.geoFeatures.js:186
jQuery.event.dispatch()load.php:4669
jQuery.event.add/elemData.handle()load.php:4338

:(

hashar assigned this task to MaxSem.Jun 17 2016, 8:48 PM

20:23 <maxsem@tin> Synchronized php-1.28.0-wmf.6/extensions/WikimediaEvents/: https://gerrit.wikimedia.org/r/#/c/294958/ (duration: 00m 33s)

I can confirm the error is gone on commons.wikimedia.org using the example given.

zhuyifei1999 moved this task from Incoming to Backlog on the Commons board.Jun 19 2016, 4:30 AM
Yurik closed this task as Resolved.Jun 19 2016, 4:33 AM

I'm guessing the bug is solved, closing