Page MenuHomePhabricator

Search page content overflows the page boundaries
Closed, ResolvedPublic2 Story Points

Description

Story
As a reader, I want the ability to see search content in a readable fashion

Description
Search page content should appear wrapped

https://en.m.wikipedia.org/w/index.php?search=wikipedia+blah

Happens on FF 47 and Chrome 51 on Android 6.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 17 2016, 8:00 PM
phuedx updated the task description. (Show Details)Jun 21 2016, 5:13 PM
Jhernandez triaged this task as High priority.Jun 21 2016, 5:14 PM
Jhernandez moved this task from Incoming to Triaged but Future on the Readers-Web-Backlog board.
jhobs added subscribers: Nirzar, jhobs.

@Nirzar Can you provide a mock and/or input on what the expected behavior should be?

Nirzar claimed this task.Aug 18 2016, 8:39 PM
dr0ptp4kt added a subscriber: dr0ptp4kt.

I can answer this one: the text should wrap.

Also, I see this regression in other browsers.

I can answer this one: the text should wrap.

Yep. with the same (as left) padding on right side.

ovasileva updated the task description. (Show Details)Sep 15 2016, 2:35 PM
ovasileva updated the task description. (Show Details)
MBinder_WMF set the point value for this task to 2.Sep 19 2016, 4:48 PM
debt added a subscriber: debt.Sep 21 2016, 1:17 PM

Change 314239 had a related patch set uploaded (by Jdrewniak):
Setting flexible width on Special:Search results

https://gerrit.wikimedia.org/r/314239

Change 314239 merged by jenkins-bot:
Setting flexible width on Special:Search results

https://gerrit.wikimedia.org/r/314239

matmarex closed this task as Resolved.Oct 5 2016, 3:41 PM
matmarex reassigned this task from Nirzar to Jdrewniak.
matmarex added a subscriber: matmarex.

(Not MobileFrontend-specific, desktop site was affected by the same issue, but it's less visible there because obviously desktop screens are wider. Not a recent regression, the problematic rule dates back to a search page styling update from 2008 rSVN32350.)