Technical Collaboration Guideline - translations
Closed, ResolvedPublic

Description

Tracking task for building the translations page of the Technical Collaboration Guideline. Currently unscheduled.

https://www.mediawiki.org/wiki/Technical_Collaboration_Guideline/Translation

Keegan created this task.Jun 22 2016, 8:34 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 22 2016, 8:34 PM
Keegan triaged this task as Normal priority.Jun 28 2016, 4:41 PM

Sections to build, still a WIP:

  • Who are the translators
  • Where do product teams contact them
  • What needs translated
  • How translations are done
Qgil added subscribers: Johan, Qgil.Aug 30 2016, 9:19 AM

How are this task task and T131581: Centralize information about translations within the movement related? They seem to have similar purposes.

Elitre renamed this task from Technical Collaboration Guildeline - translations to Technical Collaboration Guideline - translations.Aug 30 2016, 9:22 AM

How are this task task and T131581: Centralize information about translations within the movement related? They seem to have similar purposes.

T131581 look to me to be a sort of "Translation Hub," where people can go to find resources for translation and things to translate that are not just messages on meta - so documentation on mw.org, system messages on translate wiki, etc.

The "Translations" sections of the TCG is intended to outline how one gets their material translated, and then how to deliver said translated material. Its focus is on communication and delivery.

Keegan is right concerning the idea of the translation hub and the related task.

Keegan added a comment.Sep 1 2016, 4:52 PM

Started to write the page, but it's awful. Needs a complete re-visioning of purpose.

Keegan added a subscriber: Quiddity.Sep 8 2016, 6:47 PM

I'm not happy with what I've written, but @Quiddity claims there are some useful bits in there. I'm going to sit on the page through the review next quarter and see if I can figure out how to make it more useful and to the point of the TCG.

Qgil added a comment.Sep 19 2016, 4:31 PM

I have the impression that the root of the problem is that it is unclear what we want to say about translations in the TCG. This is mainly a recommendation for development teams and communities, so the basic recommendations could point to (I'm just writing down ideas that come to mind, this doesn't aim to be a draft of anything):

  • Wikimedia is a multilingual and multicultural community. Be ready for this when planning strings for your software, project descriptions, announcements, and requests for feedback.
  • Wikimedia has a community of translators willing to help, but their time, energy, and patience is limited.
    • Be conscious about new requests for translation. For instance, English-only is fine for regular updates targeting developers.
    • Volunteers are moved by their own interest and availability. They don't owe you anything. If you have tight deadlines, it is not their problem. Plan well in advance anything needing translations, involving translators in your plans, and the results will be a lot better.
    • Be concise. Shorter texts to the point have higher chances to be translated faster in more languages.
    • Think global and standard. Cultural references, slang, word plays... are very difficult to translate and most probably not required.
  • Most people in the World and in Wikimedia are not fluent English speakers. Don't forget this when asking for feedback, when reading volunteers' feedback, when discussing with them, and also when thinking about the users who are not participating because of language barriers
  • In order to soften these barriers and increase participation of non-English speakers, collaborate with tech ambassadors so they bring those discussions to their communities and/or think of basic translatable surveys with multiple options, not requiring writing text.

(etc)

In terms of form, we have apparent duplicity of content at

*https://www.mediawiki.org/wiki/Technical_Collaboration_Guideline/Translation
*https://www.mediawiki.org/wiki/Technical_Collaboration_Guideline/Milestone_communication#Translations

Keegan changed the task status from Open to Stalled.Sep 19 2016, 6:58 PM

I lost my direction. The review period will help provide clarity.

Qgil changed the task status from Stalled to Open.Sep 20 2016, 12:16 PM

"Stalled" means that no progress can be done until something else happens, and here we have an ongoing discussion. Just let this task rest and come back after a few days. :)

I would add to Quim's list:

  • define your context - translate something with technical terms and no definition for them will not be translated
    • define a glossary first
  • limit the number of updates - have a section with "future changes" (that are sure to be done) written at present tense and move these sections to the appropriate ones will be much better than asking to review translations

Is this task stalled or supposed to move to Community-Liaisons (Jan-Mar 2017)

Adjusted for the new quarter.

This page is only awaiting a little more feedback (to be had this week), I'll rewrite it and close this next week.

Keegan closed this task as Resolved.Jan 17 2017, 7:41 PM

Revisiting it with fresh eyes, and it's fine. I wasn't worried about nothing.

There was quite a bit of discussion at https://www.mediawiki.org/wiki/Topic:Te1rmc80rl239set about how to prevent translation overload by writing concisely, keep a rather descriptive style, try to organize information in modules that can be reused... None of that is mentioned in the guideline. Please reconsider.