Page MenuHomePhabricator

Initial puppet run failing for new instances in privpol-captcha
Open, NormalPublic

Description

The initial puppet run does not work for new instances in privpol-captcha.
IRC log:
[15:00:12] <tom29739> I see this in captcha-web-2: '2016-06-22T14:45:21.767173+00:00 captcha-web-2 puppet-agent[1074]: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find node 'captcha-web-2.privpol-captcha.eqiad.wmflabs'; cannot compile'
[15:01:10] <valhallasw`cloud> please create a bug for that one -- that sounds like an issue with puppet
[15:01:28] <valhallasw`cloud> (as in: the operations/puppet repo or the puppetmaster confgi)

...

[20:36:24] <tom29739> 'Warning: Unable to fetch my node definition, but the agent run will continue:#033[0m' I just spotted that in the log when I rebooted it, does that mean anything?
[20:36:50] <tom29739> Nope, still asks for a password.
[20:37:29] <tom29739> And 'rror: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find node 'captcha-web-06.privpol-captcha.eqiad.wmflabs'; cannot compile#033[0m'
[20:38:20] <tom29739> I was advised to file a bug for that earlier, but I didn't because I thought it was caused because of reusing a hostname.
[20:38:51] <tom29739> These new instances don't have reused hostnames.
[20:38:51] <bd808> And these instances are still pointed at the labs puppetmaster?
[20:38:56] <tom29739> Yep.
[20:39:11] <tom29739> I haven't touched the puppetmaster for these ones.
[20:39:38] <bd808> hmmm... yeah that's a bug somewhere. Cert isn't getting signed on the puppetmaster or something
[20:39:54] * bd808 doesn't have access to that host to debug deeper
[20:40:26] <tom29739> The very first 2 instances I ever created in the project I tried to get a project puppetmaster working, but I deleted those instances and erased the hiera config.
[20:41:02] <tom29739> Is it possible that the old, removed hiera config is somehow coming though?
[20:41:57] <bd808> possible, but not likely I don't think
[20:42:17] * tom29739 files a bug...

Event Timeline

tom29739 created this task.Jun 22 2016, 8:47 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 22 2016, 8:47 PM
chasemp triaged this task as Normal priority.Jun 27 2016, 2:50 PM
chasemp added a subscriber: chasemp.

@tom29739 whatever came of this? I somewhat recall you got it working.

@chasemp it just happens randomly, not every time but still often enough to get annoying. I don't think it's anything that I'm doing because Niharika was having the exact same issue on their project.