Page MenuHomePhabricator

HeaderTabs extension conflict with Google Charts
Closed, ResolvedPublic

Description

Due lack of some variable value checking in ext.headertabs.core.js situation when js-exception fired happens. In this example it happens when Google Charts stylesheet file attached to wiki. Exception appear on all pages regardless of headertabs tag presence.

Tested on:

  • Mediawiki 1.26
  • Headertabs (both master and REL1_26)

Steps to reproduce:

  1. Install Headertabs
  2. Attach https://www.gstatic.com/charts/44/css/util/util.css stylesheet either way to page
  3. Refresh page
  4. You will notice "ext.headertabs.core.js:42 Uncaught TypeError: Cannot read property 'length' of null" exception fired

Somehow this happens because there is no check for rules variable on line 42 of ext.headertabs.core.js which is null in this scenario.

Event Timeline

Vedmaka created this task.Jun 24 2016, 12:08 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 24 2016, 12:08 AM

Change 295776 had a related patch set uploaded (by Vedmaka Wakalaka):
fix bug T138553 Change-Id: I1fdec4b31f26aa4fd39d371a27880b9d9916a913

https://gerrit.wikimedia.org/r/295776

Change 295776 merged by jenkins-bot:
fix bug T138553 Change-Id: I1fdec4b31f26aa4fd39d371a27880b9d9916a913

https://gerrit.wikimedia.org/r/295776

Vedmaka closed this task as Resolved.Jun 24 2016, 11:50 AM