Page MenuHomePhabricator

Request project MediaWiki-extensions-reCaptcha
Closed, ResolvedPublic

Description

Requesting project creating for reCaptcha extension.

Extension adds google-captcha 2.0 to login/register page, was developed in times when ConfirmEdit did not support v2.0 Google "No-captcha". It is much simpler than ConfirmEdit and to be improved.

Event Timeline

Vedmaka created this task.Jun 24 2016, 3:29 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 24 2016, 3:29 PM
Krenair renamed this task from Request space for project MediaWiki-extension-reCaptcha to Request space for project MediaWiki-extensions-reCaptcha.Jun 24 2016, 4:36 PM
Aklapper renamed this task from Request space for project MediaWiki-extensions-reCaptcha to Request project MediaWiki-extensions-reCaptcha.Jun 25 2016, 12:49 PM

Where would you like a project to be created exactly? For the code base in Wikimedia Git? For project task management in Phabricator?

Also, https://www.mediawiki.org/w/index.php?title=Extension:ReCaptcha&oldid=2107364 states that this code is part of ConfirmEdit extension. Is that correct? If it is I am afraid that I don't understand exactly the intention behind this request. :-/

I would like to have it both in task management and Wikimedia Git.

Oh, i did not notice that page was edited and ConfirmEdit incorporated my extension, however, i think it is still reasonable to have lightweight alternative.

Danny_B triaged this task as Medium priority.Jun 30 2016, 10:56 PM

@Vedmaka: Is there an extension homepage on mediawiki.org to link to?

Going to create this, since the required data is here, and the git exists. ConfirmEdit is another captcha, so not a dupe.

Restricted Application added a project: User-Luke081515. · View Herald TranscriptJul 24 2016, 5:46 PM
Luke081515 closed this task as Resolved.Jul 24 2016, 5:49 PM

I created MediaWiki-extensions-reCaptcha, and I added the project to the repo too (rEREC extension-reCaptcha).

Danny_B removed a subscriber: Danny_B.Jul 24 2016, 7:43 PM