Execution of ?veaction=edit sometimes fails on Page: pages, emitting "Error: No class registered by that name: proofread-page"
Closed, ResolvedPublic8 Story Points

Description

When user try to load the Visual Editor in Page: pages using ?veaction=edit parameter the loading fails with the error "Error: No class registered by that name: proofread-page".

I happens because the ext.visualEditor.desktopArticleTarget.init code gets executed before ext.proofreadpage.ve.pageTarget.init and, so, the second is not able to load the ProofreadPagePageTarget

It is a follow-up of task T138489

Tpt created this task.Jun 25 2016, 8:26 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 25 2016, 8:26 AM
Tpt moved this task from Backlog to Top priority on the ProofreadPage board.Jun 25 2016, 8:27 AM
Jdforrester-WMF closed this task as Invalid.Jun 25 2016, 9:25 AM

Seems like it was just a caching bug, fixed now.

Tpt reopened this task as Open.Jun 25 2016, 12:43 PM

It still happening some time. I really thing that the first description of the issue is the right one

Jdforrester-WMF renamed this task from Makes ?veaction=edit works in Page: pages to Execution of ?veaction=edit sometimes fails on Page: pages, emitting "Error: No class registered by that name: proofread-page".Jun 25 2016, 12:48 PM
Jdforrester-WMF triaged this task as High priority.

Change 296052 had a related patch set uploaded (by Tpt):
Loads PageTarget all the time with VisualEditorPluginModules

https://gerrit.wikimedia.org/r/296052

Tpt moved this task from Top priority to In progress on the ProofreadPage board.Jun 25 2016, 1:51 PM
Jdforrester-WMF set the point value for this task to 8.Jun 30 2016, 12:06 PM

Change 296052 merged by jenkins-bot:
Remove PageTarget.init, instead load via VisualEditorPluginModules

https://gerrit.wikimedia.org/r/296052

Jdforrester-WMF closed this task as Resolved.Jul 4 2016, 7:02 AM
Jdforrester-WMF claimed this task.

From quick testing this now looks fixed. Hopefully.