Page MenuHomePhabricator

Gitblit links not redirecting to the correct moved resource unless .git is part of repo name in url
Closed, DeclinedPublic

Description

https://github.com/wikimedia/texvcjs (README.md) links to https://git.wikimedia.org/blob/mediawiki%2Fextensions%2FMath/REL1_23/texvccheck%2FREADME

which is now not the requested resource at all, but is a Phabricator diffusion start page (https://phabricator.wikimedia.org/diffusion/). It is not appropriate to use '301 Moved Permanently' in this scenario.

Event Timeline

jayvdb created this task.Jun 30 2016, 10:01 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 30 2016, 10:01 AM
jayvdb updated the task description. (Show Details)Jun 30 2016, 10:06 AM
Danny_B claimed this task.Jun 30 2016, 10:14 AM
Danny_B added a subscriber: Danny_B.

Going to check that.

Danny_B moved this task from To Triage to Backlog on the Gitblit-Deprecate board.Jun 30 2016, 10:15 AM
Danny_B triaged this task as Normal priority.Jun 30 2016, 10:23 AM
Danny_B added a project: Operations.

The issue is, that the link is not 100% correct. It's missing .git after the repo name. https://git.wikimedia.org/blob/mediawiki%2Fextensions%2FMath.git/REL1_23/texvccheck%2FREADME works.

I don't know how such links became alive, but my spider didn't find them on Gitblit page itself, thus they are perhaps some sort of "syntactic sugar / short(er) / cool(er) URLs" added OR leftovers from past when the .git extension hasn't been used. (I am not familiar with Gitblit history, just assuming on the base of the spider results.)

For the time being it would be useful to add some monitoring/logging of URLs being redirected to the Diffusion main page and their referers (cc Operations) to find out referers we can correct somehow and (undocumented) URLs like this to see if they can be added to redirect rules as well.

Ive uploaded this pull https://github.com/wikimedia/texvcjs/pull/17 to change the link.

Thanks. However, that solves only this particular case in this moment.
For future we need some more versatile solution like those I've suggested earlier.

jayvdb renamed this task from gitblit blobs not redirecting to the correct moved resource to gitblit blobs not redirecting to the correct moved resource unless .git is part of repo in url.Jun 30 2016, 11:00 AM
mmodell closed this task as Declined.Jul 15 2016, 11:31 PM
mmodell added a subscriber: mmodell.

I don't think we need to care about redirecting ancient / malformed urls.

Danny_B renamed this task from gitblit blobs not redirecting to the correct moved resource unless .git is part of repo in url to Gitblit links not redirecting to the correct moved resource unless .git is part of repo name in url.Aug 11 2016, 11:56 AM