Page MenuHomePhabricator

Mark notifications as read/unread with blue dot does not work in some circumstances
Closed, ResolvedPublic

Description

Whatamidoing reports "Every normal day begins with going to Notifications and telling it to mark someone's user talk page as read (a cross wiki notification). But when I click the blue dot, it takes me to the new thread (not what I want) and does *not* mark it read!"

I think she uses Safari.

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
ResolvedMooeypoo
Resolved Mattflaschen-WMF
ResolvedMooeypoo
ResolvedCapt_Swing
Resolved SBecker
OpenNone
ResolvedMooeypoo
ResolvedSBisson
ResolvedMooeypoo
Resolved jmatazzoni
ResolvedMooeypoo
ResolvedMooeypoo
ResolvedCatrope
ResolvedMooeypoo
Resolved jmatazzoni
ResolvedMooeypoo
ResolvedMooeypoo
OpenNone
ResolvedMooeypoo
ResolvedNone
ResolvedSBisson
OpenNone
OpenNone

Event Timeline

Restricted Application added a subscriber: Zppix. · View Herald TranscriptJul 1 2016, 8:29 AM
Qgil renamed this task from Mark notifications as read/unread with blue dot does not work to Mark notifications as read/unread with blue dot does not work in some circumstances.Jul 1 2016, 9:53 AM
Qgil added a subscriber: Qgil.Jul 1 2016, 9:55 AM

It works for me on Chrome 49.0.2623.108.

Maybe a screenshot would help. It sounds like the div or click area for the notification at the left is invading the area of the blue dot, but even if I make the window very narrow I can still click the blue dot without problems.

Elitre added a subscriber: Elitre.Jul 1 2016, 10:16 AM
Catrope added a subscriber: Catrope.Jul 1 2016, 1:51 PM

If she uses Safari it's very plausible that this is a CSS issue / browser bug. If I get a chance later today I'll try to test with Safari VM.

In T139122, @IKhitron wrote:

Hello. It's about a week that opening alert does not mark all the revisions as read (T132525) automatically . Great news. But this created another problem. Clicking on view change opens the revision diff but does not mark it as read. One should go back to the alerts, and mark it manually (or open the page in place of revision instead, by clicking on the alert). Could you fix this, please?

IKhitron added a comment.EditedJul 1 2016, 2:12 PM

Hello, @Trizek-WMF? Why do you think this task has something with T139122? This one is a bug. That one a request for improvement of different feature.

Here is a short demo showing how the notification "unread" dot, when showing a notification from another wiki, does not behave properly.

Also, that blue dot is way too small! :)

Hello, @Trizek-WMF? Why do you think this task has somethinh with T139122? This one is a bug. That one a request for improvement of different feature.

My bad!

I'm currently running Safari Version 9.1.1 (10601.6.17) on Mac OS 10.10.5 (14F1808).

I believe I've experienced the same issue as @CKoerner_WMF, although it happened fast and I haven't been able to reproduce it.

Chrome 51.0.2704.103 Mac 10.11.5

If she uses Safari it's very plausible that this is a CSS issue / browser bug. If I get a chance later today I'll try to test with Safari VM.

I didn't get a chance to do this, so someone else should take a look.

Mooeypoo removed Mooeypoo as the assignee of this task.Jul 5 2016, 6:26 PM
Mooeypoo moved this task from Untriaged to Ready for Pickup on the Collab-Team-2016-Apr-Jun-Q4 board.
Mooeypoo added a subscriber: Mooeypoo.
jmatazzoni added a subscriber: jmatazzoni.EditedJul 5 2016, 11:30 PM

I just tested this on beta and on the live site in Mac Safari version 9.0 (11601.1.56), and did not see any problem.

This is half-fixed.

Clicking on this blue dot at Meta:

takes me to James F's user talk page on mw.org. I am not clicking on the message; I am clicking on the blue dot itself (note the presence of the tooltip), whose alleged purpose is to mark the notification as read without taking me to the page.

This is happening now, in Safari 9.1.1 and Firefox 47.0 on Mac OS 10.10.5 (14F1808).

However, as an improvement over the previous behavior, clicking the dot is marking the notification as read. The next step is to make it stop taking me to the page that I don't want to read.

I'm still not seeing it. @Whatamidoing-WMF, would you mind trying this on the beta site? That would have the newest code. Perhaps whatever it is has been fixed...

Pings work correctly on the Beta Cluster. (I don't know if Flow threads do.)

I was not able to actually reproduce the bug, but watching the screen recording I noticed that that the blue dot was actually turned to the empty circle upon clicking indicating that the status of the notification was, in fact, changed.
In the screen recording the blue dot was clicked several time and there was a movement of cursor (with continuing clicking?)- so the user was redirected to the page.

If you are interested to hear this, yesterday I saw again the same problem: I marked the blue dot manually as read, the number of notifications was 0, and an hour after that a new notification received and the old one surprisingly was remarked blue again, so the number become 2.

Elena writes:

In the screen recording the blue dot was clicked several time and there was a movement of cursor (with continuing clicking?)- so the user was redirected to the page.

Yes, I saw that too. But later in the recording the blue dot itself clearly does redirect to a different page.

Anyway, @Whatamidoing-WMF, if it's working for you now, as you note above (I think), can we close this? (@IKhitron, your count problems would seem to be a different issue.)

jmatazzoni closed this task as Resolved.Jul 12 2016, 4:28 PM
jmatazzoni claimed this task.

So the task name is too comprehensive. I thought this is a problem. It happens at least once every day in the last days, whebn the blue dot appeared.

Thx, @IKhitron - yes, there may be something. But it's really hard to reproduce. I tried to test it - still did not get definite results (with reproducible steps). I've set up some tests for tomorrow and will report back.

Thank you. If a I can help somehow - I'll be glad.

To summarize two issues reported on the task:

  1. The "click on the blue dot redirection" issue - also filed as T139339: Cross-wiki mark as read redirects to the page instead of actually mark as read - is in the process of being fixed.
  2. The issue when the notification status seemingly "reverts back to unread" refers to T138569: Global notifications still appearing as unread on other wikis even after reading them

I was checking T138569: Global notifications still appearing as unread on other wikis even after reading them suspecting that the issue is more severe (e.g. local notifications spontaneously revert their status) - all looks fine.

Unfortunately, I don't see a way how to prove this point. But it happened today again, 7 times.

Mooeypoo removed jmatazzoni as the assignee of this task.Jul 13 2016, 9:36 PM

If you are interested to hear this, yesterday I saw again the same problem: I marked the blue dot manually as read, the number of notifications was 0, and an hour after that a new notification received and the old one surprisingly was remarked blue again, so the number become 2.

@IKhitron okay, this is worrying - we can't seem to properly reproduce a bug you're experiencing fairly regularly. I want to pinpoint the issue without confusing things further in this more general bug report, so I split this problem up to its own task T140309: In some cases notifications that were marked read, reappear as unread again

I've raised a couple of questions, if you could help me try and sort it out in that task, that will be extremely helpful. Thanks!