Page MenuHomePhabricator

Archive #ShoutWiki
Closed, DeclinedPublic

Description

ShoutWiki seems to be unused. It contained the only task which has been resolved on Dec 20, 2015 and no other tasks ever.

Event Timeline

Danny_B created this task.Jul 5 2016, 12:49 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 5 2016, 12:49 AM

Shoutwiki is a people organisation tag with 4 people from the team (minus @Aklapper), The following extensions also belong to them:

  • Extension:AJAXPoll (AJAXPoll)
  • Extension:Answers (Social-Tools)
  • Extension:Automatic Board Welcome (Social-Tools)
  • Extension:Challenge (Social-Tools)
  • Extension:CookiePolicy
  • Extension:EnhanceContactForm
  • Extension:GlobalNotice
  • Extension:GlobalUserPage (GlobalUserPage)
  • Extension:GlobalUserrights
  • Extension:GoogleDocs4MW
  • Extension:LockDownEnglishPages
  • Extension:NewsBox
  • Extension:NewSignupPage (Social-Tools)
  • Extension:NumberOfWikis
  • Extension:Phalanx
  • Extension:Prezi
  • Extension:Quantcast
  • Extension:ShoutWiki Ads
  • Extension:ShoutWiki API
  • Extension:ShoutWiki Interwiki Magic
  • Extension:SoftwareVersion
  • Extension:StaffEdits
  • Extension:StaffPowers
  • Extension:StatCounter.com Integration
  • Extension:Theme (#Mediawiki-extensions-Theme)
  • Extension:Video (Social-Tools)
  • Extension:Vine
  • Extension:Whitelist Pages
  • Extension:WikiForum (WikiForum)

Personally I don't see any major harm in leaving it active, since deactivated tags still show up in most tag selection locations anyway.

Luke081515 closed this task as Declined.Jul 24 2016, 5:51 PM
Luke081515 added a subscriber: Luke081515.

Going to decline it, see above. Since there are maintaining a lot of extensions, and I don't see an disadvantage, if we leave that project active.

Danny_B reopened this task as Open.Jul 24 2016, 7:30 PM

Apart from empty history of the project, the lack of reaction from the team actualy clearly shows that the project is unused.

Apart from empty history of the project, the lack of reaction from the team actualy clearly shows that the project is unused.

Or that it's not used for following tasks about the tag itself. :)

Apart from empty history of the project, the lack of reaction from the team actualy clearly shows that the project is unused.

...or that the team has had other, far more pressing issues to deal with. A Phabricator tag isn't going to hurt anyone (and I believe we have tags for individual users, too; so if we can have those in here, why not ShoutWiki?), so obviously commenting on this ticket has been on our to-do list, just not at the very top.

As @Peachey88 mentioned, we maintain a bunch of extensions (and skins, too!). Often the issues found on a ShoutWiki site also affect MediaWiki and/or the extension/skin in question in general, as ShoutWiki runs a relatively vanilla MediaWiki with very few core code hacks. We have our own Phabricator at phabricator.shoutwiki.com which we use to track technical tickets -- sometimes issues specific to our setup, sometimes more generic issues reproducible elsewhere -- and host non-public code repositories.

Just as much as the next developer or user, I appreciate the effort to try to keep Phabricator nice and tidy. But in my opinion, if anything, we need more third-party developers in Wikimedia Phabricator, not less. Sometimes a project may choose to migrate all of its (relevant) issues to Wikimedia Phabricator, like how Brickimedia did; sometimes the WMF Phab is used for certain tasks and a different, internal tool is used for other tasks (which kinda is the case with ShoutWiki and our Phabricator installation).

Apart from empty history of the project, the lack of reaction from the team actualy clearly shows that the project is unused.

Maybe we have better things to be doing, than repeating the same, perfectly valid points other people in the community have already made for us?

Many of the things I envisaged being tagged with this project/group are already filed and I definitely don't have the time to go through and create lots of noise in old bugs.

lcawte moved this task from Backlog to Admin/Other on the ShoutWiki board.Jul 24 2016, 9:21 PM
Danny_B added a comment.EditedJul 24 2016, 9:58 PM

Maybe we have better things to be doing, than repeating the same, perfectly valid points other people in the community have already made for us?

None of them actually refuted the major argument of the tag being unused.

Many of the things I envisaged being tagged with this project/group are already filed and I definitely don't have the time to go through and create lots of noise in old bugs.

Many? There is total of 5 tasks marked with this tag, of which 2 are purely administrational (create the tag, archive the tag). At the time of creation of this task there was the only other existing (closed on Dec 20 2015, though) task in the history of this tag.

Isarra closed this task as Declined.Jul 25 2016, 12:26 AM
Isarra added a subscriber: Isarra.

This doesn't make sense.