Page MenuHomePhabricator

Please upload Wikimania 2016 Youtube videos to Wikimedia Commons
Closed, ResolvedPublic

Description

Event Timeline

Yiyi created this task.Jul 5 2016, 12:07 PM
Restricted Application added subscribers: Zppix, Poyekhali, JEumerus and 3 others. · View Herald TranscriptJul 5 2016, 12:07 PM
Aklapper renamed this task from Please upload large files to Wikimedia Commons to Please upload Wikimania 2016 Youtube videos to Wikimedia Commons.Jul 5 2016, 3:24 PM
Poyekhali moved this task from Incoming to Backlog on the Commons board.Jul 6 2016, 5:07 AM
Dereckson assigned this task to Yiyi.EditedJul 8 2016, 3:27 AM
Dereckson added a subscriber: Dereckson.

@Yiyi You need to convert them to ogg or webm first.

We also need to prepare for each file the content of the first revision.

There is a tool to help for that: https://tools.wmflabs.org/video2commons/: it automates the task, uses youtube-dl to download from YouTube, then ffmpeg to convert.

It will convert and allow to describe the videos and at the end will give you the URLs to submit here.

I'm assigning back the ticket to you so you can start the process. Feel free to reset assignee or assign it back to me when you're done on video2commons (or another way to convert the videos).

Yiyi added a comment.EditedJul 8 2016, 8:15 PM

@Yiyi You need to convert them to ogg or webm first.
We also need to prepare for each file the content of the first revision.
There is a tool to help for that: https://tools.wmflabs.org/video2commons/: it automates the task, uses youtube-dl to download from YouTube, then ffmpeg to convert.
It will convert and allow to describe the videos and at the end will give you the URLs to submit here.
I'm assigning back the ticket to you so you can start the process. Feel free to reset assignee or assign it back to me when you're done on video2commons (or another way to convert the videos).

Hi @Dereckson, with the tool I've uploaded a lot of videos. 6 of them had an error (I'll try again tomorrow), while just 1 of them is too large to be uploaded by myself.

You can find this large video here:

wget http://v2c3.wmflabs.org/Wikimania_2016_-_The_System_of_interdependent_Wikimedia_Projects_by_Susanna_Mkrtchyan.webm{,.txt} # md5: 81a3b776cefcaac91fa09fd95b898655

Other 3 videos are outstanding.

Thanks

Yiyi added a comment.Jul 9 2016, 11:24 AM

Thanks. One is ok, the other no, but I can try again with the tool.

If a second pass with the tool doesn't work, you can ask @zhuyifei1999 for assistance if there is an error message during the ffmpeg conversion. For error during fetch operation, just retry, sometimes youtube-dl fails to get the video.

And the worst part is during upload process.

I find in the redis a file named Wkimania 2016 - Wiki Loves Monuments, how to Preserve the World's Culturale Heritage got pywikibot.Error: APIError: stashfailed: Invalid chunk offset [help:See https://commons.wikimedia.org/w/api.php for API usage; offset:950253464]

I believe this error is caused by T128358, and I'm still trying to workaround it in T129216

zhuyifei1999 renamed this task from Please upload Wikimania 2016 Youtube videos to Wikimedia Commons to Search.Jul 10 2016, 9:42 AM
zhuyifei1999 renamed this task from Search to Please upload Wikimania 2016 Youtube videos to Wikimedia Commons.
zhuyifei1999 updated the task description. (Show Details)
zhuyifei1999 closed this task as Resolved.Jul 10 2016, 9:48 AM

Checked his uploads manually, seems all done. The last one succeeded after a few attempts.

(idk why and how I changed the title)

Yiyi added a comment.Jul 10 2016, 7:50 PM

Checked his uploads manually, seems all done. The last one succeeded after a few attempts.
(idk why and how I changed the title)

Thanks. Now they are ok.