Page MenuHomePhabricator

When a user only has foreign notifications, the special page shows "You have no notifications."
Closed, ResolvedPublic

Event Timeline

SBisson created this task.Jul 6 2016, 7:23 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 6 2016, 7:23 PM

Change 297633 had a related patch set uploaded (by Sbisson):
Special:Notifications JS even when no local notifications

https://gerrit.wikimedia.org/r/297633

Mooeypoo added a comment.EditedJul 8 2016, 6:10 PM

I can see in the code how this would happen, but I can't personally reproduce this. If I have no local notifications, the page loads with "local" wiki as [ 0 ] and then shows me all notifications (which are unread)

I even marked everything as read in my remote wikis, and still loaded a full JS page with "local" source marking [0], no foreign sources in the sidebar, and the list of read notifications from the local source showing.

Code-wise, this fix looks perfectly fine, so I'm leaning towards merging it even just for code consistency, but I'm slightly worried I couldn't reproduce the bug first, in case this exposes followup issues; am I missing something?

Okay, I just got it -- an entirely fresh new user completely without notifications. It was hard to reproduce for me, because my local wiki sends out a 'welcome' notification, but I see it now. Thanks for the fix, @SBisson

Change 297633 merged by jenkins-bot:
Special:Notifications JS even when no local notifications

https://gerrit.wikimedia.org/r/297633

Etonkovidova added a comment.EditedJul 8 2016, 10:10 PM

@Mooeypoo

It was hard to reproduce for me, because my local wiki sends out a 'welcome' notification

Yes, the wiki in which a fresh user created an account would receive 'Welcome', but on another wiki there will be zero notifications.

Checked in betalabs - looks fine.

If cross-wiki notification is turned off - still 'No notifications' is displayed

jmatazzoni closed this task as Resolved.Jul 12 2016, 5:58 PM