Page MenuHomePhabricator

[Regression] Change size indicators (e.g. (+25)) on Special:Contributions are not colored
Closed, ResolvedPublic

Description

e.g. https://commons.wikimedia.org/wiki/Special:Contributions/Aude

(-37) / (+25) etc. are no longer colored or styled

they are still colored on Special:Recentchanges and still on enwiki (wmf.8)

Event Timeline

aude created this task.Jul 6 2016, 8:08 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 6 2016, 8:08 PM
bd808 added a subscriber: bd808.Jul 6 2016, 8:11 PM

The html has "mw-plusminus-pos" and "mw-plusminus-neg" classes on these data points. Those styles are defined in resources/src/mediawiki.special/mediawiki.special.changeslist.css. Maybe just some RL statements missing for that special page?

Change 297644 had a related patch set uploaded (by BryanDavis):
Add mediawiki.special.changeslist to SpecialContributions

https://gerrit.wikimedia.org/r/297644

Hmm, looks like we missed Special:Contributions in 9e458504c7b49097ac10c9fc185ee2b2447b8e23. Sorry!

Change 297644 merged by jenkins-bot:
Add mediawiki.special.changeslist to SpecialContributions

https://gerrit.wikimedia.org/r/297644

matmarex closed this task as Resolved.Jul 6 2016, 9:17 PM
matmarex assigned this task to bd808.
matmarex removed a project: Patch-For-Review.

I'll have the fix backported to wmf.9. Thanks for spotting the issue!

Restricted Application added a project: User-bd808. · View Herald TranscriptJul 6 2016, 9:17 PM

Change 297696 had a related patch set uploaded (by Bartosz Dziewoński):
Add mediawiki.special.changeslist to SpecialContributions

https://gerrit.wikimedia.org/r/297696

(The buggy patch is also present in wmf.8, but b88cc6edd1be2cc0199a9d33c013d8e73642bc73 isn't, so only wmf.9 is affected.)

Change 297696 merged by jenkins-bot:
Add mediawiki.special.changeslist to SpecialContributions

https://gerrit.wikimedia.org/r/297696

Mentioned in SAL [2016-07-06T23:52:28Z] <legoktm@tin> Synchronized php-1.28.0-wmf.9/includes/specials/SpecialContributions.php: Add mediawiki.special.changeslist to SpecialContributions - T139522 (duration: 00m 25s)

Krinkle renamed this task from Change size indicators (e.g. (+25)) on Special:Contributions are no longer colored to [Regression] Change size indicators (e.g. (+25)) on Special:Contributions are not colored.Jul 6 2016, 11:53 PM
Krinkle added a project: Regression.
bd808 moved this task from To Do to Done on the User-bd808 board.Jul 19 2016, 11:41 PM
bd808 moved this task from Done to Archive on the User-bd808 board.Sep 1 2016, 5:12 PM