Page MenuHomePhabricator

Array must contain at least one element in ApiEchoNotifications. php on line 341
Closed, ResolvedPublic

Description

Seen in prod and deployment-prep:

Warning: max(): Array must contain at least one element in /srv/mediawiki/php-1.28.0-wmf.8/extensions/Echo/includes/api/ApiEchoNotifications.
php on line 341

Event Timeline

MaxSem created this task.Jul 6 2016, 9:36 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 6 2016, 9:36 PM

Change 297785 had a related patch set uploaded (by Sbisson):
Check for empty array before calling max()

https://gerrit.wikimedia.org/r/297785

SBisson claimed this task.Jul 7 2016, 1:06 PM
SBisson moved this task from Untriaged to Needs Review on the Collab-Team-2016-Apr-Jun-Q4 board.

Change 297785 merged by jenkins-bot:
Check for empty array before calling max()

https://gerrit.wikimedia.org/r/297785

Checked betalabs logs - no warning; the code is in /srv/mediawiki/php-master/extensions/Echo/includes/api/ApiEchoNotifications.php.

jmatazzoni closed this task as Resolved.Jul 27 2016, 5:44 PM