Page MenuHomePhabricator

Identify inaugural SWAT members for the European SWAT window
Closed, ResolvedPublic

Description

Experienced deployers (can help train):

Need/want (more) training:

Event Timeline

greg created this task.Jul 6 2016, 11:09 PM

The European SWAT idea got triggered following a conversation with mobile devs @Jhernandez and @phuedx . So I guess they will be happy to propose patches :]

The i18n team (with @KartikMistry and @Nikerabbit ) sounds like a good candidate as well.

I am definitely going to be leading up the European SWAT until folks are comfortable rolling it by themselves.

I would also like to contribute, but I need training.

phuedx added a comment.Jul 7 2016, 9:00 AM

If @hashar could host a hangout (on air?) whenever he deploys, that'd be great. It's been a while since I pushed bits out to the servers so I need to get my sea legs back.

Seems I posted this to the wrong task:

I would be interested in doing this. But it probably takes at least a week for me to be able find the time (need to switch my computer among other things) and it is unclear at this time how much time I can invest in the future. I would be interested in training someone who actually wants to do this, but in the past I couldn't overcome the obstacles.

I am interested to help, though I won't be available every day. It has been a long time since I did deployments so I too would benefit from training.

If such window is acceptable from an ops point of view, I can be available during this time slot.

+1 to @hashar and @phuedx, I think after (another) watching session we could rotate per patch and get some hands on experience while under supervision for a few windows.

greg updated the task description. (Show Details)Jul 8 2016, 7:10 PM

I put names in the description in two categories: experienced and need/want (more) training. Fix/add as appropriate!

greg added a comment.Jul 13 2016, 12:04 AM

@hashar @Dereckson @JanZerebecki: When would you all be available to start doing this window? Note that Antoine will be on vacation starting July 30th so there's only 2 of you confirmed for the month of August (ish). Though we can probably get @Nikerabbit up to speed (along with @phuedx @Jhernandez and @zeljkofilipin) quickly enough.

So, everyone in the description who I just pinged: would you be able to start attending this window (6am Pacific/13:00 UTC) the week of July 25th? July 18th (next week)? Later?

I'm available next week.

I would like to help for deployment if there will be such time slot :) Also a training would be awesome. I did some deployments with services but not super familiar with deployments in mediawiki.

Ladsgroup updated the task description. (Show Details)Jul 13 2016, 8:22 AM

@hashar can do until end of July.

Lets open the window starting next week (week of of July 18th), announce it and get patches candidates to deploy / pair over.

would you be able to start attending this window (6am Pacific/13:00 UTC) the week of July 25th? July 18th (next week)? Later?

I am available next week.

RobH removed a subscriber: RobH.Jul 13 2016, 3:15 PM
greg added a comment.Jul 15 2016, 6:31 PM

My instinct is not to start this next week for these reasons:

  • it's Friday and I still haven't announced it (though I have poked the ops@list once this week and once the week before, to warn them with no responses)
  • Antoine and Zeljko (the two members of RelEng who can be around at that time) will only be around for 1 week before they both go on "European-length summer vacations" :)
  • With the above: I don't have anyone other than @Dereckson lined up who affirmatively can do the window and has not expressed a desire for training. I'm worried about overloading Dereckson and/or not being able to cover a SWAT when there are requested patches. It's not wise to start a new service with a SPOF :)

With the above, and after briefly chatting with @hashar and @zeljkofilipin to sanity check, I don't plan to institute this until after they both return from vacation (the week of August 22nd).

Of course, I'm open to people commenting here who A) don't need extra training (iow: you've done a SWAT before) and B) are willing to join the SWAT team at least until Aug 22nd. If 2 people come forward who meet that criteria we can start it early.

For me the training will be swift and fast, I know scap very well (beside contributing in it, I migrated ORES to use scap), I have requested several complicated SWAT patches (An example) so I know the process of requesting and deploying patches rather well. I've even proper rights (access to tin, hhvm restart sudo rule, etc.) but since I've never done a SWAT deploy it seems necessary to me. These are just FYI, Feel free to give me a strict training if you think so.

greg added a comment.Jul 15 2016, 6:59 PM

@Ladsgroup I think your assessment is correct enough :)

Down to 1.5 ;)

@greg I now have deployment access and am also based in Europe! (Just in case you want to add me to come list)

Not totally familiar with scap yet, but I have requested many things to be swatted (thus familiar with that process). And pushed 2 backports out of the door yesterday!

hashar updated the task description. (Show Details)Jul 27 2016, 9:59 AM

@Addshore I have enlisted you for SWAT conscription :-}

greg closed this task as Resolved.Jul 28 2016, 5:53 PM
greg claimed this task.

Alright, I think we've identified everyone and @hashar's plan at T137970#2501313 makes sense.

Everyone who has volunteered needs to make sure they complete the new SWAT deployer check list before they can SWAT: https://wikitech.wikimedia.org/wiki/SWAT_deploys#New_SWAT_Team_member_check-list

Resolving this task (please file follow-up ones for individuals needing the required access, see that link ^).

Restricted Application added a project: User-greg. ยท View Herald TranscriptJul 28 2016, 5:53 PM