Page MenuHomePhabricator

Fresh 1.27.0 install: ParameterAssertionException: Bad value for parameter maxKeys: must be above zero
Closed, DeclinedPublic

Description

Please look at this post in MediaWiki support project for a full description.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 7 2016, 5:06 AM

Please provide relevant information here so it can be found here when searching.

Exception encountered, of type "Wikimedia\Assert\ParameterAssertionException"

[V3uvKsCoKvAAAFjq0lIAAAVl] /p/mw-config/index.php Wikimedia\Assert\ParameterAssertionException from line 63 of /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/vendor/wikimedia/assert/src/Assert.php: Bad value for parameter maxKeys: must be above zero

Backtrace:

#0 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/libs/objectcache/HashBagOStuff.php(49): Wikimedia\Assert\Assert::parameter(boolean, string, string)

#1 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/libs/objectcache/CachedBagOStuff.php(46): HashBagOStuff->__construct(array)

#2 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/session/SessionManager.php(172): CachedBagOStuff->__construct(EmptyBagOStuff)

#3 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/session/SessionManager.php(85): MediaWiki\Session\SessionManager->__construct()

#4 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/WebRequest.php(700): MediaWiki\Session\SessionManager::singleton()

#5 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/session/SessionManager.php(121): WebRequest->getSession()

#6 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/Setup.php(745): MediaWiki\Session\SessionManager::getGlobalSession()

#7 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/includes/WebStart.php(137): require_once(string)

#8 /mnt/web006/e3/17/56865117/htdocs/lursenorg/p/mw-config/index.php(36): require(string)

#9 {main}

Aklapper renamed this task from Fresh install of MW 1.27 crashes with an assert error to Fresh 1.27.0 install: ParameterAssertionException: Bad value for parameter maxKeys: must be above zero.Jul 7 2016, 9:35 AM
Aklapper added a project: MediaWiki-General.
PleaseStand closed this task as Declined.Jul 7 2016, 11:11 AM
PleaseStand added a subscriber: PleaseStand.

There should be no way this backtrace could have been generated unless the value of the constant INF is not greater than 0, and that should not happen.

Searching bugs.php.net, I found a known issue, reported by a Strato customer, with old versions of Solaris. As your site (www.lursen.org) seems to be hosted by Strato, this is probably not a bug in MediaWiki.

@PleaseStand
Thanks for your reply. I reported the issue to the Strato dev that commented on this known issue.
I'll keep my fingers crossed (or I'll move to another ISP).

Dear Group Members,

the discussed error was fixed. Thus, MediaWiki should work in the most recent PHP version 7. If you have any questions left, please do not hesitate to contact us.

Best regards,

STRATO AG

Hi, I just tested with a fresh install of MediaWiki 1.27.1 and php version 7 on Strato servers.
Seems to work OK for me now.

Ti30 added a subscriber: Ti30.May 1 2018, 4:13 PM

Got this Exception while upgrading from 1.23 branch to 1.27, too. Simply changing webspace's PHP to 7 didn´t fix my issue right away... had to search / fix .htaccess entries from Strato with code similar to
...
AddType application/x-httpd-php7 .php