Page MenuHomePhabricator

Fatal error: Invalid static property access: AbuseFilter::filters in AbuseFilterCheck.php on line 121
Closed, ResolvedPublic

Description

seen in logstash as of 1.28.0-wmf.9

Details

Related Gerrit Patches:
mediawiki/extensions/AbuseFilter : wmf/1.28.0-wmf.10Make getFilter() public for extension hooks
mediawiki/extensions/AbuseFilter : masterMake getFilter() public for extension hooks
mediawiki/extensions/ContentTranslation : wmf/1.28.0-wmf.10Avoid accessing private $filters field
mediawiki/extensions/ContentTranslation : masterAvoid accessing private $filters field

Event Timeline

mmodell created this task.Jul 7 2016, 8:49 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 7 2016, 8:49 PM
matmarex assigned this task to aaron.Jul 15 2016, 9:31 PM
matmarex added a subscriber: matmarex.

Probably caused by https://gerrit.wikimedia.org/r/#/c/296491/ (which was to fix other log spam: T138529).

Change 299268 had a related patch set uploaded (by Aaron Schulz):
Make getFilter() public for extension hooks

https://gerrit.wikimedia.org/r/299268

Change 299268 merged by jenkins-bot:
Make getFilter() public for extension hooks

https://gerrit.wikimedia.org/r/299268

Change 299438 had a related patch set uploaded (by Aaron Schulz):
Avoid accessing private $filters field

https://gerrit.wikimedia.org/r/299438

Change 299438 merged by jenkins-bot:
Avoid accessing private $filters field

https://gerrit.wikimedia.org/r/299438

matmarex closed this task as Resolved.Jul 18 2016, 4:05 PM
matmarex removed a project: Patch-For-Review.

Change 299707 had a related patch set uploaded (by BryanDavis):
Avoid accessing private $filters field

https://gerrit.wikimedia.org/r/299707

Change 299707 merged by jenkins-bot:
Avoid accessing private $filters field

https://gerrit.wikimedia.org/r/299707

Mentioned in SAL [2016-07-19T15:49:28Z] <thcipriani@tin> Synchronized php-1.28.0-wmf.10/extensions/ContentTranslation/includes/AbuseFilterCheck.php: SWAT: [[gerrit:299707|Avoid accessing private $filters field (T139657)]] (duration: 00m 26s)

Change 299862 had a related patch set uploaded (by Chad):
Make getFilter() public for extension hooks

https://gerrit.wikimedia.org/r/299862

Change 299862 merged by jenkins-bot:
Make getFilter() public for extension hooks

https://gerrit.wikimedia.org/r/299862

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:11 PM