Page MenuHomePhabricator

HTTP 400 error for '/w/extensions/MobileFrontend/resources/skins.minerva.base.styles/?d41d8'
Closed, ResolvedPublic1 Story Points

Description

Ignoring API and internal traffic, the most common request url currently hitting Varnish is:

/w/extensions/MobileFrontend/resources/skins.minerva.base.styles/?d41d8

This yields a HTTP 400 Bad Request ("Invalid file type" source) because it is not a valid file (it's a directory, no file specified).

It's coming from the MobileFrontend's main stylesheet at link, containing:

.search-overlay .search,.header .search{padding:.5em 28px;
background-image:url(/w/extensions/MobileFrontend/resources/skins.minerva.base.styles/?d41d8);

Which is the output of:

https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/a5ab7b71dc/resources/skins.minerva.base.styles/ui.less#L22-L27

.search-overlay,
.header {
	.search {
		padding: .5em 28px;
		.background-image-svg( 'magnifying-glass.svg', '' );

Event Timeline

Krinkle created this task.Jul 8 2016, 10:35 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 8 2016, 10:35 PM
dr0ptp4kt triaged this task as Normal priority.Jul 11 2016, 5:11 PM
Krinkle renamed this task from [Regression] HTTP 400 error for '/w/extensions/MobileFrontend/resources/skins.minerva.base.styles/?d41d8' to HTTP 400 error for '/w/extensions/MobileFrontend/resources/skins.minerva.base.styles/?d41d8'.Jul 11 2016, 10:20 PM
bmansurov moved this task from To Do to Doing on the Reading-Web-Sprint-76-Retrosprekfast board.

Change 298483 had a related patch set uploaded (by Bmansurov):
Add missing PNG files

https://gerrit.wikimedia.org/r/298483

Change 298483 merged by jenkins-bot:
Add missing PNG file and consolidate identical css code

https://gerrit.wikimedia.org/r/298483

bmansurov removed bmansurov as the assignee of this task.Jul 14 2016, 3:59 PM
bmansurov added a subscriber: bmansurov.
Jdlrobson closed this task as Resolved.Jul 14 2016, 9:30 PM
Jdlrobson claimed this task.

Signed off.

@Jdlrobson @bmansurov Story points? Whomever did the task.

Jdlrobson set the point value for this task to 1.Jul 18 2016, 5:21 PM

Change 300315 had a related patch set uploaded (by Krinkle):
wmfstatic: Ensure all errors have some small amount of server-side caching

https://gerrit.wikimedia.org/r/300315

Change 300316 had a related patch set uploaded (by Krinkle):
Add missing PNG file and consolidate identical css code

https://gerrit.wikimedia.org/r/300316

Change 300315 merged by jenkins-bot:
wmfstatic: Ensure all errors have some small amount of server-side caching

https://gerrit.wikimedia.org/r/300315

Change 300316 abandoned by Krinkle:
Add missing PNG file and consolidate identical css code

Reason:
Redundant now that all wikis are on wmf.11

https://gerrit.wikimedia.org/r/300316

This was also the cause for the 200X increase in mediawiki-static traffic:

And back to normal when https://gerrit.wikimedia.org/r/298483 rolled out to all wikis:

While the url had a hash and could be cached if the path existed, it cacheable because it was not even a valid file path (directory instead of file). As such static.php emitted an uncacheable 400 error (not a 404 error, which is cacheable). This is is also fixed as of https://gerrit.wikimedia.org/r/300315.