Page MenuHomePhabricator

Stylesheet missing or its parsing prematurely ended for logged user on English Wikisource
Closed, InvalidPublic

Description

Using Firefox v48.06b in windows 7.

when logged in, pages of the Author: namespace are garbled. This is the actual author page:
https://en.wikisource.org/wiki/Author:Ellis_Paxson_Oberholzer

image of page with login: https://en.wikisource.org/wiki/File:Ellis_Paxson_Oberholzer_logged_in.jpg
image of page when not logged in: https://en.wikisource.org/wiki/File:Ellis_Paxson_Oberholzer_not_logged_in.jpg

Steps taken:

  1. Deleted all .js and .css files completely related to my username. This includes, vector, monobook and modern. Global pages were always empty. There is no change in the results.
  2. Checked page in Google Chrome and the results are the same.

Firefox developer's console output:

Unknown property 'speak'. Declaration dropped.Author:Ellis_Paxson_Oberholzer
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:615
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:1495
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:2330
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:3291
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:3974
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:4788
Unknown property '-moz-outline-style'. Declaration dropped.load.php:1:6003
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:8266
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:8716
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:9096
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:9480
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:9860
Unknown property 'orphans'. Declaration dropped.load.php:1:10388
Unknown property 'widows'. Declaration dropped.load.php:1:10397
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:14903
Unknown property 'zoom'. Declaration dropped.load.php:1:15023
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:15042
Unknown property 'zoom'. Declaration dropped.load.php:1:16567
Expected declaration but found '*'. Skipped to next declaration.load.php:1:16570
Unknown property 'zoom'. Declaration dropped.load.php:1:22584
Unknown property 'user-select'. Declaration dropped.load.php:1:22764
Unknown property 'zoom'. Declaration dropped.load.php:1:25483
Expected declaration but found '*'. Skipped to next declaration.load.php:1:25486
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:27739
Unknown property 'user-select'. Declaration dropped.load.php:1:27821
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:28899
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:29936
Unknown property 'zoom'. Declaration dropped.load.php:1:31987
Expected declaration but found '*'. Skipped to next declaration.load.php:1:31990
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:32467
Expected end of value but found '\9 '. Error in parsing value for 'list-style-image'. Declaration dropped.load.php:1:32655
Expected end of value but found '\9 '. Error in parsing value for 'list-style-image'. Declaration dropped.load.php:1:32725
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:34870
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:34890
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:35648
Unknown pseudo-class or pseudo-element '-ms-input-placeholder'. Ruleset ignored due to bad selector.load.php:1:36058
Unknown pseudo-class or pseudo-element '-webkit-search-decoration'. Ruleset ignored due to bad selector.load.php:1:36180
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:37266
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:37286
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:37833
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:38294
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:38759
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:39202
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:39882
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:40487
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:41360
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:41380
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:42287
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:42307
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:45465
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:45485
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:46271
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:46291
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:47638
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:47658
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:48482
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:48502
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:49340
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:49360
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:50065
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:50177
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:51343
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:53554
Error in parsing value for 'background-image'. Declaration dropped.load.php:1:53574
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:54633
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.load.php:1:55041
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:2:979
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:2:1735
Unknown property 'zoom'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:3:83
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:3:1142
Unknown property '-moz-background-clip'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:1230
Unknown property '-moz-background-origin'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:1260
Unknown property '-moz-background-inline-policy'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:1298
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:2589
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:2751
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:2858
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:3075
Expected color but found 'bottom'. Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:3203
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:3830
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:3988
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:4184
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:4282
Expected color but found 'bottom'. Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:4:4400
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:5:1429
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:5:2826
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:6:1666
Expected 'none', URL, or filter function but found 'alpha('. Error in parsing value for 'filter'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:6:1890
Expected 'none', URL, or filter function but found 'alpha('. Error in parsing value for 'filter'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:6:1983
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:7:1508
Error in parsing value for 'background-image'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:7:1528
Unknown property 'user-select'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:8:114
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:9:2665
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:9:5231
Unknown property 'zoom'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:9:5384
Expected declaration but found '*'. Skipped to next declaration.Author:Ellis_Paxson_Oberholzer:9:5387
Expected declaration but found '*'. Skipped to next declaration.Author:Ellis_Paxson_Oberholzer:11:248
Unknown property 'zoom'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:11:268
Unknown property 'user-select'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:13:624
Error in parsing value for 'unicode-bidi'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:13:1008
Error in parsing value for 'unicode-bidi'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:13:1037
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:15:1672
Expected 'important' but found 'ie'. Expected ';' or '}' to terminate declaration but found 'ie'. Declaration dropped.Author:Ellis_Paxson_Oberholzer:15:2815
Expected end of selector or a user action pseudo-class after pseudo-element but found ':'. Ruleset ignored due to bad selector.Author:Ellis_Paxson_Oberholzer:15:2893

Event Timeline

Ineuw created this task.Jul 11 2016, 12:41 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 11 2016, 12:41 AM
Danny_B added a subscriber: Danny_B.

Can't reproduce (FF 47.0.1 @ W7x64), it will be obviously related to some of your styles or scripts.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 11 2016, 12:47 AM

This script is linked from your global common.js and has been modified recently. https://meta.wikimedia.org/w/index.php?title=User:He7d3r/Tools/TemplateScript.js&action=history

Does that occur only on this page or on any other?

Did you try to purge your browser cache?

Danny_B renamed this task from When logged in to English Wikisource, contents of Author namespace are garbled. to Stylesheet missing or its parsing prematurely ended for logged user on English Wikisource.Jul 11 2016, 12:54 AM
Danny_B triaged this task as Low priority.
Ineuw added a comment.Jul 11 2016, 1:14 AM

Danny, no offense intended, but I am not User:He7d3r. And, please read the bug report. I have no global, or any user .js or .css and NEVER had Global settings!!! Purged my cache more often than the Spanish inquisition burned the Aztecs and the Jews. . . . and why is this a low priority? I am willing to bet that someone else will notice the problem sooner or later in other Wikisource projects, just as my last bug reported, popped up in other Wikisource projects.

Sorry, that was https://meta.wikimedia.org/wiki/User:Ineuw/common.js linking it, I misplaced it with global.js.

Low priority because I can't reproduce and everything seems to be correctly loaded.

Ineuw added a comment.Jul 11 2016, 1:51 AM

I suspect that the problem may be with my global login. I have ~95 wikisites attached to my global login. Suggest that I change my password, email it to you to be used for a predetermined time (15 minutes?). Login with my username and see if it's reproducible.

Please never share your password with anyone.

Does a new/fresh user account have this issue?

Have you looked at which gadgets you have enabled at https://en.wikisource.org/wiki/Special:Preferences#mw-prefsection-gadgets?

Danny_B closed this task as Invalid.Jul 11 2016, 2:33 AM

You had gadget "Site" turned off. It is necessary for formatting.

Ineuw added a comment.Jul 11 2016, 3:37 AM

Thanks Danny_B. You are right. It was not checked before I removed all the gadgets, as I kept an screenshot of my gadget selection. Now everything works.

Ineuw added a comment.Jul 11 2016, 4:36 AM

@MZMcBride. The password given was a temporary password for 15 minutes or so, and is no longer valid. But since you brought it up, I suggest that Mediawiki programmers/technicians should have access to our editing options and gadget settings for test purposes.

I am also curious as to why such an important component of the site software is a gadget?

I suspect that the problem may be with my global login. I have ~95 wikisites attached to my global login. Suggest that I change my password, email it to you to be used for a predetermined time (15 minutes?). Login with my username and see if it's reproducible.

Never, ever do that. Doing that will usually have your account locked by WMF staff, and your advanced rights revoked. Bad idea.

Base added a subscriber: Base.EditedJul 12 2016, 6:35 AM

What? Why should WMF staff care about it? Shared accounts are not even prohibited in all the projects. E.g. on Commons there is no rule I know which prohibits them. And in the projects where shared accounts are prohibited it is clearly the jurisdiction of local admins to deal with. In case if you are actually right and the staffers are indeed hunting such accs it looks like a serious issue to deal with.

P.S. I am sorry for off-topic, I just couldn't pass by this not commenting.
P.P.S. I do find sharing a password a bad idea, especially in conjunction with declaring the fact in a public place, but what you say is either wrong or something new and scary

User's gadgets were not appropriate for site functionality.

What? Why should WMF staff care about it? Shared accounts are not even prohibited in all the projects. E.g. on Commons there is no rule I know which prohibits them. And in the projects where shared accounts are prohibited it is clearly the jurisdiction of local admins to deal with. In case if you are actually right and the staffers are indeed hunting such accs it looks like a serious issue to deal with.
P.S. I am sorry for off-topic, I just couldn't pass by this not commenting.
P.P.S. I do find sharing a password a bad idea, especially in conjunction with declaring the fact in a public place, but what you say is either wrong or something new and scary

@Base Please read the Terms of Use of Wikimedia Foundation that relates to user accounts. The statement is pretty clear.

Ineuw added a comment.Jul 12 2016, 3:34 PM

Mea culpa. It was not done with malice. But, there should be a mechanism
for IT staff to see a user's settings. I would like to know why it isn't
so? Also, if this feature is so important, why allow a user to turn it off
or on? Furthermore, as far as I understand it, this feature is unique to
Wikisource.

there should be a mechanism
for IT staff to see a user's settings. I would like to know why it isn't
so?

People with the right server-level access - deployment, restricted, or ops - can see users settings. We can just log into the right servers, run a privileged command and we get a database prompt from which we can query almost everything. It's just that no one commenting on this task before me has those permissions. Quite a few actual MediaWiki developers have never requested them, and none of those have commented here until now either. Unfortunately it's not something that can be automatically given out to every single person who knows enough to help people with technical problems, but their help is valuable nonetheless. It's just not a good idea to go sharing passwords to accounts.