Page MenuHomePhabricator

When saving, be informed about mentions you sent (#9)
Closed, ResolvedPublic

Description

Survey: 2015
Original wish (German):https://de.wikipedia.org/wiki/Wikipedia:Umfragen/Technische_W%C3%BCnsche_2015/Echo-Benachrichtigungen#Bei_Speichern_Hinweis_.C3.Bcber_abgegebene_Benachrichtigungen

Update sites on-wiki:

Related Analytics:
https://grafana.wikimedia.org/dashboard/db/echo-mention-errors counts the failures according to error type

Hypotheses of underlying problem:
The current system of mentioning people is ambiguous and hard to understand, since in order to send out a mention some requirements have to be met
Hypothesis 1: Editors, especially new ones, have a hard time understanding why a mention is send out or not
Hypothesis 2: Currently, it is very difficult to find out, if a mention has been sent out or not.
Hypothesis 3: People sometimes don’t sign text chunks that include a user link, because they don’t want to mention that person. Sometimes they don’t sign the chunks, because they simply forgot to do so.

Scoping by TCB-Team:

1.) Write an opt-in feature that allows users to receive a notification whenever they successfully sent a mention or a mention failed to send
2.) Remove unnecessary restrictions to mention sending if possible
3.) Update https://www.mediawiki.org/wiki/Manual:Echo#Technical_details for more clarity, what the requirements are

Workboard: Mention-Notification
Related tasks that are out of scope for the TCB-team:
https://www.mediawiki.org/wiki/User:Legoktm/pings is a great suggestion of how to solve the ambiguity of mentions. It seems like a great idea for the future, but might involve lots of communication with all communities.

Related Objects

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 11 2016, 4:54 PM
Restricted Application added a subscriber: Luke081515. · View Herald TranscriptJul 22 2016, 10:21 AM
Alsee added a subscriber: Alsee.Aug 23 2016, 6:02 PM

I hope Notifications isn't considered a substitute for T68078 (indicating mentions when the page is saved).

Checking and clearing the Notification panel immediately after each and every message save would get extremely tedious very fast. The alternative is to check notifications occasionally, but there is no way to realistically recall off the top of your head every mention that should have existed over the last N message you sent. You would basically have to scour your own contribution history for any message that was intended to mention and which is missing from the Notification panel.

This information is most salient at the moment the message is saved. It should should be visible when the save is confirmed.

@Alsee wrote:

I hope Notifications isn't considered a substitute for T68078

I'm sorry, but I think we discovered complications with that idea. @Catrope or @Lea_WMDE, are we still pursuing the idea of notifying on save, or did that hit a wall?

I'm sorry, but I think we discovered complications with that idea.

When we started working on the wish, we initially planned to implement a way to indicate mentions when the page is saved. However, at the point of saving the page, no processing for mentions has been done yet. Therefore, when the message "The page has been saved" appears, the system does not know yet whether any mentions will be sent. The reason for this is to be able to quickly save pages - hence all mention processing is delayed to a later step in the process. Changing this has been discussed in T136928, but since such a change would influence the performance of all saves of all pages, the decision was taken against it. Therefore, unfortunately, from our side, this is the best we could do.

Pine added a subscriber: Pine.Sep 16 2016, 9:33 PM

@Lea_WMDE moved this task from Feature Development to Done on the German-Community-Wishlist-Main-Wishes board.

@Lea_WMDE: Does that mean the status of this task should be resolved? Or what is left to do here?

thiemowmde closed this task as Resolved.Wed, Oct 9, 8:19 AM
thiemowmde claimed this task.