Page MenuHomePhabricator

[Regression pre wmf.10] Math node is appearing as UNIQ marker in Read mode
Closed, DuplicatePublic

Description

Steps to reproduce:
Insert a math function in a page using VE and Save the page

Observed Result:
Math node is appearing as UNIQ marker in Read mode

Event Timeline

Ryasmeen created this task.Jul 12 2016, 6:50 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 12 2016, 6:50 PM
Jdforrester-WMF triaged this task as High priority.Jul 12 2016, 6:52 PM
Jdforrester-WMF added a subscriber: Physikerwelt.
Physikerwelt added a comment.EditedJul 13 2016, 7:11 AM

I can think of two possible reasons for the problem,

  • the math marker is been modified
  • the parserhook after tidy is not being called.

It has to be investigated if the full marker including the invisible char, appears in the output page to exclude the first option. Unfortunately, I'm currently not availible.

This is still happening in wmf.15. Will be great if anyone look into it.

I'd be happy to look into that. Can you send a link to an example page where this problem occours.

It has to be investigated if the full marker including the invisible char, appears in the output page to exclude the first option. Unfortunately, I'm currently not availible.

it seems to be connected with the cite extension. If I put comments around the cite commands https://gist.github.com/physikerwelt/d979eb7aad0f5f264a9cc13413d54a53 it does not show the strip markers

Izno moved this task from Unsorted backlog to Defect backlog on the Cite board.Aug 22 2016, 3:52 PM

See also T138453 (could be a duplicate)