Page MenuHomePhabricator

Namespace is repeated in notification link
Closed, ResolvedPublic

Description

Hello,

I am using Newsletter 1.26+47b66b1 with Echo 1.26+401ba91 on MediaWiki 1.26.3.
When I send a newsletter using a namespaced page name, the namespace is added twice in the link.
For example, if my page is Foo:Bar, it will link to Foo:Foo:Bar.

Related Objects

Event Timeline

Rudloff created this task.Jul 14 2016, 7:10 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 14 2016, 7:10 PM

This seems to be fixed on the 1_27 branch.

@01tonythomas: Can you confirm / do you know? ^

@01tonythomas: Can you confirm / do you know? ^

These issues are addressed in our latest change of shifting to Contenthandler (https://gerrit.wikimedia.org/r/295670 ). The same is pulled in http://newsletter-test.wmflabs.org/ and I can see that the error reported is fixed neatly there.

I just checked the same on the master branch too, and it seems fixed there too.

@01tonythomas: So would you like to resolve this task or not?

@01tonythomas: Would you like to resolve this task or not?

Qgil closed this task as Resolved.Aug 25 2016, 9:55 AM
Qgil claimed this task.

Heh. Sorry for being the late guy here. This task will get resolved only once our contenthandler patch gets merged :)

Qgil removed Qgil as the assignee of this task.Aug 25 2016, 1:12 PM
Qgil added a subscriber: Qgil.

btw, I need to know if this bug still exists. Can somebody give it a test run ?

I can still reproduce on the REL1_26 branch.

I can still reproduce on the REL1_26 branch.

Alright. Thank you. I would love this to be tested in master too, as I merged the contenthandler changesets yesterday. Once that change go deep, we might've to even drop all the existing newsletters.

Filip added a subscriber: Filip.Dec 11 2016, 12:39 PM

@01tonythomas @Rudloff @Aklapper I cant recreate this. When i make new announce to "Foo:bar" it links correctly to "Foo:bar". I'm using master branch.

I can't reproduce anymore with 1.28+88234fa.

So i think this is not valid GCI task

FlipGCI, can you attach two screenshots (one with your announce form, and the other with the Echo notificaiton) ?

01tonythomas closed this task as Resolved.Dec 11 2016, 1:09 PM
01tonythomas claimed this task.

Nice. Happy that it got fixed. Would've been fixed during the contenthandler migration

Qgil awarded a token.Dec 13 2016, 10:25 AM