Page MenuHomePhabricator

Populate gu_auth_token for existing users
Closed, ResolvedPublic

Description

rECAUaf893bc63d66: Set gu_auth_token when adding new users will populate gu_auth_token for all new users on creation, avoiding the need for CentralAuthUser->getAuthToken() to call CentralAuthUser->resetAuthToken(). However, this does not fix things for the existing users who do not have this field populated. To avoid various issues caused by these resetAuthToken() calls (e.g. T139970), we should run a maintenance script to fill the field after 1.28.0-wmf.11 is deployed everywhere.

Event Timeline

Anomie created this task.Jul 15 2016, 3:56 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 15 2016, 3:56 PM
Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptJul 19 2016, 7:54 PM

Does the maintenance script already exist or does it still need to be written?

I put something together in terbium:/home/anomie/setEmptyCATokens.php, just waiting on the train.

Mentioned in SAL [2016-07-22T15:24:49Z] <anomie> Starting script to populate empty gu_auth_token [[phab:T140478]]

Anomie closed this task as Resolved.Jul 23 2016, 12:22 PM

Script has completed.