Page MenuHomePhabricator

HTTP 404 error (or sometimes 502 error) when trying to access the Control Panel of PAWS
Closed, ResolvedPublic

Description

I'm trying to access to the PAWS Control Panel and Jupyter shows me a 404 error and said "You are requesting a page that does not exist!". If I try to access to a terminal happens the same with the same messages.

Event Timeline

Restricted Application added a subscriber: Zppix. · View Herald TranscriptJul 16 2016, 1:31 AM

Hi! Can you try logging out and back in? you can log out via
https://paws.wmflabs.org/paws/hub/logout

Hi @yuvipanda! I was going to make your instructions but when I access again now, the errors was fixed. I'm going to keep in mind your instructions to future situations. I will make a feedback if it happens again.

Regards.

Ivanhercaz added a comment.EditedJul 16 2016, 6:29 PM

Hi @yuvipanda, it has happened again. I followed your instructions but the error persist. Any more ideas?

Do other operations work? Like opening a notebook or terminal?

Only works the PAWS/Hub/Home. Should I shutdown the server and start it again?

Yes, can you try that?

It has been solved restarting the server, I will keep in mind that for the next time that it happens. But, what could it be happen? I mean, why that error? Thank you for your help yuvipanda.

PAWS works well in my main account(info-farmer) but not in my bot account(info-farmerBot) .The following error still exists. Details One of my friend also facing this issue.

404 : Not Found, You are requesting a page that does not exist!

Strainu added a subscriber: Strainu.Apr 6 2017, 7:49 AM

@yuvipanda, I get the same error as @Info-farmer on starting the server for my bot account. This is quite annoying, as most wikis require a bot account for pywikibot. I tried logging out and in, different browser&computer etc. I even removed the app from the wiki settings and then re-authorised it, but no change. According to stackoverflow, the 404 on starting the server seems to indicate an issue starting the VM.

Strainu added a comment.EditedApr 6 2017, 6:15 PM

I was able to make it work after stopping the server on my main account, but now I'm getting a 502 error when accessing https://paws.wmflabs.org/paws/user/Strainubot. Apparently there is an issue with accounts with the same prefix.

Netol added a subscriber: Netol.Apr 30 2017, 9:47 AM

Hi,

I'm experiencing the same problem with a bot account I just created:
https://paws.wmflabs.org/paws/user/Netol_BOT
404 : Not Found

You are requesting a page that does not exist!

I can't start servers with that account

Thanks.

Netol added a comment.Apr 30 2017, 9:55 AM

I was able to make it work after stopping the server on my main account, but now I'm getting a 502 error when accessing https://paws.wmflabs.org/paws/user/Strainubot. Apparently there is an issue with accounts with the same prefix.

Just to confirm that it worked for me after stopping the server on my main account (which also starts with the same word)

It's finally working for me too (no 502, I still need to stop the server on the main account).

Netol added a comment.Apr 30 2017, 1:12 PM

I've seen just a few random nginx 502 errors, it's probably not related as I saw them before creating the second account

Cannot reproduce.
I am at https://paws.wmflabs.org/paws/user/MyUserName/tree? and click "Control Panel" at the top and end up on https://paws.wmflabs.org/paws/hub/home

Aklapper renamed this task from "404 - Not found" when I tried to access to PAWS Control Panel to HTTP 404 error (or sometimes 502 error) when trying to access the Control Panel of PAWS.Jul 21 2017, 10:03 AM

@Aklapper, have you tried doing so with a bot account while having a server started on your main account? The bot probably has to have MainAccountBot as username (that's the case for me)

R96340 added a subscriber: R96340.Jul 31 2017, 4:16 AM
This comment was removed by R96340.
R96340 added a comment.Aug 3 2017, 5:15 AM

I tried to restart the notebooks, terminals, server, all computers logged-in my account, re-log-in my account in all of my computers ,and it still happened. It seems unsolved.

Re-adding @yuvipanda since I believe he was accidentally removed.

Is this still the case with paws.wmflabs.org now? It's running on a completely different backend!

Strainu added a comment.EditedAug 29 2017, 8:27 PM

@yuvipanda: Yes, absolutely, I could reproduce it just now. I lauched Strainu's server, then tried to log in as Strainubot and I get a
"500 : Internal Server Error
Failed to start your server. Please contact admin."

Stopping the main account's server solved the issue.

Chicocvenancio triaged this task as High priority.Feb 25 2018, 8:13 PM
Chicocvenancio added a subscriber: Chicocvenancio.

Is this still an issue? Seems like it could be one of the bugs related to T185434 that have been resolved/worked around.

Netol removed a subscriber: Netol.Feb 25 2018, 8:17 PM

@Chicocvenancio , I was able to start the bot server while my user's server was on, so my steps to reproduce no longer apply.

Chicocvenancio closed this task as Resolved.Mar 2 2018, 5:17 PM
Chicocvenancio claimed this task.