Page MenuHomePhabricator

Remove deprecated wikibase config variables from configurations
Closed, ResolvedPublic1 Story Points

Description

From: https://phabricator.wikimedia.org/T138788#2463523

The result of this is any site using the sole config variable $wgMFUseWikibaseDescription = true from before June 27th to show taglines who upgrades will now lose their tagline unless they turn on $wgMFDisplayWikibaseDescriptions immediately.

Find where $wgMFUseWikibaseDescription is still used and add the new config $wgMFDisplayWikibaseDescriptions = [ 'tagline' => true ].

Remove the old variables after the changes in T138788 roll out (21st of July).

AC

  • Wikis with old configuration variables and wikibase descriptions enabled keep the descriptions enabled as the config changes/deprecations take effect in rollout
  • Old configuration variables are removed and configuration is up to date and lean
  • The fallback deprecated config variables should remain in MobileFrontend to allow time for 3rd parties to catch up

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 18 2016, 10:51 AM

@dr0ptp4kt I've pulled this in as it is a followup from last sprint 76 and sensitive to the train schedule.

Needs priority and estimation.

@Jdlrobson This is what we needed right?

MBinder_WMF triaged this task as High priority.Jul 18 2016, 4:33 PM
dr0ptp4kt set the point value for this task to 1.Jul 18 2016, 4:37 PM

Change 299615 had a related patch set uploaded (by Jdlrobson):
Wikidata description config cleanup

https://gerrit.wikimedia.org/r/299615

Have prepared patch. Would appreciate review prior to Thursday.

Ready to be SWATted.

Change 299615 merged by jenkins-bot:
Wikidata description config cleanup

https://gerrit.wikimedia.org/r/299615

Done but amongst all this Wikidata description testing I found we've caused another minor regression.. T141067

phuedx reassigned this task from Jdlrobson to dr0ptp4kt.Jul 22 2016, 9:05 AM

@Jhernandez, @jhobs, @phuedx, @bmansurov, your review for signoff requested.

dr0ptp4kt removed dr0ptp4kt as the assignee of this task.Jul 26 2016, 2:22 PM

Looks good to me.

phuedx assigned this task to bmansurov.Jul 26 2016, 4:38 PM

^ Looks like cookie licking to me…

What seems to be the problem, officer @phuedx? I've checked the mediawiki-config repo for old config variables and didn't find any.

@bmansurov: You're now fully responsible for signing off this task! Congratulations!

@dr0ptp4kt Can you clarify if you needed one dev to signoff on this, or all 4 that were @-mentioned?

Just one will do.

bmansurov closed this task as Resolved.Jul 27 2016, 1:23 PM

The task is done although the related task T141067 is being worked on. Since this task is about removing deprecated config vars I call it done.

Reference: https://github.com/wikimedia/operations-mediawiki-config/blob/master/wmf-config/InitialiseSettings.php#L14257 and https://github.com/wikimedia/operations-mediawiki-config/blob/master/wmf-config/InitialiseSettings-labs.php#L562

bmansurov removed bmansurov as the assignee of this task.Jul 27 2016, 1:24 PM