Page MenuHomePhabricator

ExtensionDistributor gives error message "Unable to fetch extension list!"
Closed, ResolvedPublic

Description

For at least the past 24 hours, the Extension Distributor has failed with the message "Unable to fetch extension list!" when navigating to https://www.mediawiki.org/wiki/Special:ExtensionDistributor. This behaviour has been witnessed in multiple browsers.

Event Timeline

Mogigoma created this task.Jul 19 2016, 1:09 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJul 19 2016, 1:09 PM
chasemp triaged this task as Normal priority.Jul 19 2016, 1:19 PM
Reedy added a subscriber: Reedy.

MW is getting "Received HTTP code 403 from proxy after CONNECT" from url-downloader.eqiad

Reedy added a comment.Jul 19 2016, 2:50 PM
		if ( $extList === false ) {
			$extList = $this->fetchRepositoryList();
			$wgMemc->set( $key, $extList, 3600 );
		}

also feels a bit strict. We're storing an empty array, so it's not trying to fetch it either, as an empty array !== false... Swapping for !$extList would be better

Reedy added a comment.Jul 19 2016, 3:32 PM

This is likely caused by T140658

Legoktm raised the priority of this task from Normal to Unbreak Now!.Jul 19 2016, 5:07 PM
Restricted Application added subscribers: Luke081515, TerraCodes. · View Herald TranscriptJul 19 2016, 5:07 PM

It works now

Legoktm assigned this task to demon.Jul 19 2016, 5:19 PM
Legoktm closed this task as Resolved.
Legoktm added subscribers: demon, Legoktm.

Fixed by @demon by reverting the changes to $wgHttpProxy. Caches might need ~30 minutes to fully clear and be re-populated, but I think most of it should work now.