Page MenuHomePhabricator

[betalabs-Regression] FF only Special:Notifications: to match space between weekday label and date
Closed, DeclinedPublic

Description

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:47.0) Gecko/20100101 Firefox/47.0

Comparing with Chrome. Safari is the same as Chrome. Browsers were checked with full screen display.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 23 2016, 1:04 AM
Quiddity renamed this task from [betalabs-Regression] FF only Special:Notifications: too mach space between weekday label and date to [betalabs-Regression] FF only Special:Notifications: to match space between weekday label and date.Jul 25 2016, 9:06 PM
Catrope closed this task as Declined.Jul 25 2016, 9:23 PM
Catrope added a subscriber: Catrope.

This is a browser bug in Firefox. The width of the label and even the kerning of the letters in it change back and forth when you toggle display: inline-block;. Unfortunately, we need that for the ::first-letter { text-transform: capitalize; } rule for T141092: Months in the notifications should be upper- or lowercase, as appropriate per each language.

Closing because this is a bug in Firefox. I'll report it upstream later.