Page MenuHomePhabricator

Update gerrit to 2.12.3
Closed, ResolvedPublic

Description

The release notes are at

It fixes a few things.

Note the changes include fixes from the 2.11.x series which are not explicitly listed in the 2.12.3 release notes.

Note https://gerrit-review.googlesource.com/#/c/82611/ (2.12.4 was not released when the upgrade to 2.12.3 occurred.)

Event Timeline

Paladox created this task.Jul 25 2016, 8:25 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2016, 8:25 AM
hashar triaged this task as Medium priority.Jul 25 2016, 8:32 AM
jayvdb added a subscriber: jayvdb.Jul 25 2016, 8:03 PM
jayvdb updated the task description. (Show Details)Jul 26 2016, 10:16 AM

Hi I'm wondering when you get to building the gerrit 2.12.3 war, could we also backport https://gerrit-review.googlesource.com/#/c/80830/ please. Since it fixes T141329 as I have confirmed it fixes it.

demon added a comment.EditedAug 3 2016, 5:07 PM

If that is urgent, then we can wait for 2.12.4. Otherwise vanilla 2.12.3 will be fine. Custom backports are a pain.

@demon, you doint need to backport the actuall comit with all the data, you just edit the file by hand and add the fix.

And nope not urgent.

demon added a comment.Aug 3 2016, 6:32 PM

Editing the file by hand is even worse!

Paladox added a comment.EditedAug 3 2016, 6:34 PM

@demon Oh, but I managed it, you just edit the file. But if you think that it will cause problems, doint do it. As you said it is worse. But it would fix T141329 and instead of us having to wait another few months for us to upgrade to a new gerrit version.

demon added a comment.Aug 3 2016, 6:42 PM

The point is backporting things at all. If we're going to cherry-pick it, we would do it by actually cherry-picking the commit into a custom branch, not by editing the file and pretending we didn't :)

Paladox added a comment.EditedAug 3 2016, 6:47 PM

@demon Oh, could we cherry pick, or is that the same,

@demon https://gerrit-review.googlesource.com/#/c/80830/ that was merged now. So we can build ontop of the gerrit stable 2.12 branch which should include all the fixes.

Paladox renamed this task from Update gerrit to 2.12.3 to Update gerrit to 2.12.4.Aug 11 2016, 10:42 AM
Paladox updated the task description. (Show Details)

@demon lol just after updating to gerrit 2.12.3 they released gerrit 2.12.4 https://gerrit-review.googlesource.com/#/c/82611/

@Paladox: This task was about updating to 2.12.3 specifically. Why did you entirely change its scope by making this task about updating to 2.12.4, so this task is not resolved by now?

jayvdb renamed this task from Update gerrit to 2.12.4 to Update gerrit to 2.12.3.Aug 16 2016, 10:05 AM
jayvdb closed this task as Resolved.
jayvdb updated the task description. (Show Details)

I'd expect we let the dust settle on the 2.12.3 upgrade before attempting the 2.12.4 upgrade, even if it looks like it should be simple to do.

@Aklapper hi I changed it since I thought they were going to release it then but they didn't. But looks like they are now.

I'd expect we let the dust settle on the 2.12.3 upgrade before attempting the 2.12.4 upgrade, even if it looks like it should be simple to do.

2.12.4 fixes a bug that correctly tells you who authored the patch in the inline edit.

demon added a comment.Aug 16 2016, 3:48 PM

@demon lol just after updating to gerrit 2.12.3 they released gerrit 2.12.4 https://gerrit-review.googlesource.com/#/c/82611/

It has not been released just yet. There's no v2.12.4 tag and there's no published *.war file :)

demon added a comment.Aug 16 2016, 3:49 PM

I'd expect we let the dust settle on the 2.12.3 upgrade before attempting the 2.12.4 upgrade, even if it looks like it should be simple to do.

Eh, there's no schema change so it should just be a matter of rebuilding our package and dropping it on the server. 2.12.3 only took me a day or so :)