Page MenuHomePhabricator

Patchsets created through web interface attributed to the wrong user
Closed, ResolvedPublic

Description

I used the web interface to first edit the commit message (PS2) and then the content (PS3) of https://gerrit.wikimedia.org/r/#/c/300856/ . However, grrrit-wm reported:

18:16:16 <grrrit-wm> (PS2) WMDE-Fisch: Echo notifications for successful mentions [extensions/Echo] - https://gerrit.wikimedia.org/r/300856 (https://phabricator.wikimedia.org/T139623)
18:22:52 <grrrit-wm> (PS3) WMDE-Fisch: Echo notifications for successful mentions [extensions/Echo] - https://gerrit.wikimedia.org/r/300856 (https://phabricator.wikimedia.org/T139623)

This is incorrect: WMDE-Fisch created PS1, but I created PS2 and PS3. If I had made the equivalent changes from the command line, my name would appear here instead of Fisch's.

Attribution does still seem to work correctly for rebases done through the web interface:

18:19:27 <grrrit-wm> (PS18) Catrope: Add mention failure notification for multiple section edits [extensions/Echo] - https://gerrit.wikimedia.org/r/298419 (https://phabricator.wikimedia.org/T138942) (owner: WMDE-Fisch)

Event Timeline

Catrope created this task.Jul 26 2016, 1:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 26 2016, 1:45 AM
Legoktm edited projects, added grrrit-wm; removed GerritBot.Jul 26 2016, 1:46 AM

This is fixed in gerrit 2.12.3

See https://gerrit-documentation.storage.googleapis.com/ReleaseNotes/ReleaseNotes-2.11.9.html which was added into gerrit 2.12.3

Issue 4055: Fix subject for Updated Changes lines on push.
When a change was updated it showed the subject from the previous patch set instead of the subject from the new current patch set.

https://bugs.chromium.org/p/gerrit/issues/detail?id=4055

Looking at it I'm not sure if it is fixed in gerrit 2.12.3 not really sure.

Could you file this upstream please to see what there response is since it is either a bug in gerrit or the bot needs updating to support gerrit 2.12 better:

Paladox triaged this task as Medium priority.Jul 29 2016, 10:16 PM

I think this requires a change in the bot code, maybe gerrit had api changes.

@Catrope hi could you file this as a bug upstream please?

This comment was removed by Paladox.
Paladox added a subscriber: valhallasw.

It seems gerrit 2.12 adds a new command https://gerrit-documentation.storage.googleapis.com/Documentation/2.8.1/rest-api-changes.html#get-included-in

compared to gerrit 2.8 that didn't have that command.

Change 302416 had a related patch set (by Paladox) published:
Fix this so it correctly says who the user is changing the patch

https://gerrit.wikimedia.org/r/302416

I think I found the problem and fixed it in the above patch.

Since message.uploader.name only works when uploading through http or ssh and not through new gerrit edit ui.

We have to change it to message.author.name which should get the correct auther as that is used in when commiting on a patch it gets the correct author.

Change 302416 merged by jenkins-bot:
Fix this so it correctly says who the user is changing the patch

https://gerrit.wikimedia.org/r/302416

Mentioned in SAL [2016-08-03T10:12:10Z] <paladox> testing some changes to see weather it fixes T141329

Patch has been submitted upstream https://gerrit-review.googlesource.com/#/c/80830/ not sure if it will fix it for us without testing.

But looks like it will.

Paladox moved this task from Backlog to Patch proposed upstream on the Upstream board.

I have tested the patch and it seems to fixe this.

I haven't tested with irc but have with stream-events and it deffintly seems to have both the current user and owner now.

I confirmed by adding the information to https://phabricator.wikimedia.org/P3630$27

Paladox moved this task from Bugs & stuff to Maybe fixed? on the Gerrit board.Aug 5 2016, 4:08 PM
jayvdb added a subscriber: jayvdb.

So this needs to wait for a 2.12.4 upgrade.

This T148876 is related.

demon closed this task as Resolved.Nov 15 2016, 6:26 PM
demon claimed this task.
demon closed subtask T143089: Update gerrit to 2.12.5 as Resolved.